FreePBX | Register | Issues | Wiki | Portal | Support

Source RPM for Asterisk 16.3?


(M Wise) #1

I’m not sure where else to post this, but the source RPM for Asterisk 16.3 appears to be missing from the development repos when I try to retrieve it. The 13.26-2 SRPM is already there, but 16.3 has been out for getting close to a week and I’m still getting no matches when I try to download the 16.3 SRPM.


(Andrew) #2

I haven’t been able to find it either. I’m trying to re-build asterisk to include the Cisco usecallmanager patch but when I try to get the 16.3 source I get 16.2.1-1 which doesn’t cut it :frowning:

If you find it please share.


(Tom Ray) #3

There is no “if found, please share” with this. Asterisk does not release RPMs or packaged releases. Sangoma creates the RPMs for FreePBX distro users to pull from their repos for easy management/updates. You will have it when everyone else has it and that’s when it is in the repos.

Now you could do yum install sangoma-devel that puts you in the devel/testing repos and 16.3.0-1 is in it. I’m running that version on all my systems.


(Andrew) #4

hmmm.

I did “yum install sangoma-devel” but then when I pulled down the SRPM it only had pulled in the asterisk16.2.1-1

I did find an older copy of the usecallmanager patch for 16.2 and am trying that route (it did appear to build, now to test)

Last time i tried this with the Asterisk 13 I was able to pull in the source RPM’s (following wiki.freepbx. org/display/FOP/Cisco sorry, as a new user i can’t post a complete link yet) and it the process worked. This time adjusting for asterisk 16 it nearly worked except it was the 16.2.1 srpm that was pulled down and the current patch was for 16.3 (which wasn’t close enough). Hopefully 16.2 will treat us well.


(M Wise) #5

Yes, the 16.3.0-1 RPM is there, but the SRPM is (still) not there. I also don’t see the reason for the hairsplitting between Sangoma and Asterisk given Sangoma acquired Digium. Plus this is the FreePBX distro forum, not the asterisk forum…not sure where else I’m supposed to report a missing package.

The asterisk source tar is virtually useless for use in FreePBX unless you want to spend your day trying to get it to build in the distro.


(Henning Reich) #6

The inlcuded asterisk*.tar.gz inside the SRPM is exactly the same as the asterisk*.tar.gz from the public asterisk project. So maybe its a solution for you: (I’m not allowed to add links, so all links are “code”)

Follow the steps described here:
https://wiki.freepbx.org/display/PPS/Applying+patches+to+Asterisk+in+distro+SNG7

At the point <NOW ADD YOUR PATCHES> you add the wanted tar.gz from
http://downloads.asterisk.org/pub/telephony/asterisk/
or https://downloads.asterisk.org/pub/telephony/asterisk/old-releases/
and set the correct version in the asterisk16.spec file.

Edit: okay, seems no solutiion at all. Build fails. Maybe this is the reason, no SRPM exist yet :smiley: