Sound prompts in wrong language


#1

Hi,
I temporary replaced my vega 200G gateway with a A101DE card.
Everything went fine except that i lost all my voice prompts of the default language ‘gr’.
All sound prompts are now in Language 'en’
Althrough i thought that the sound prompts are controlled from the Admin-Sound Languages
i had to find out that i had to change the Dahdi config - Global Settings to Greek to be able to
get back my voice prompts in the default custom language.
Is this normal or am i missing something ?
Is Dahdi or the sound languages module controlling the the system global language?

Thanks


(Andrew Nagy) #2

Yes but not for Dahdi.


#3

You might also make sure that your

/etc/asterisk/indications.conf

files reflect that the

country=gr

and you have a properly set section

[gr]
description = Greece
ringcadence = 1000,4000
dial = 425/200,0/300,425/700,0/800
busy = 425/300,0/300
ring = 425/1000,0/4000
congestion = 425/200,0/200
callwaiting = 425/150,0/150,425/150,0/8000
dialrecall = 425/650,0/25
record = 1400/400,0/15000
info = !950/330,!1400/330,!1800/330,!0/1000,!950/330,!1400/330,!1800/330,!0/1000,!950/330,!1400/330,!1800/330,!0/1000,0
stutter = 425/650,0/25


#4

You mean that the sound languages module is controlling the system global language for sip and/or channels coming from a gateway but not DAHDI channels.These are controled from the Dahdi config - Global Settings. Right ?

Thanks


#5

Almost. Dahdi is a different channel driver to the other built in ones (not really part of asterisk per se) so the hardware needs the “indications.conf” to parse and appropriately respond to the ‘signalling’ audio it receives and the driver needs to know where to look for it’s playable audio files.

https://www.voip-info.org/wiki/view/chan_dahdi.conf


#6

Ok.Got it.
Will i have any other restrictions if i need for example to change the language for an extension or inbound route or any other announcements ?
Thanks


Default language, system recordings and wrong announcement language
Changing sound language
#7

Probably not, the SIP stacks and FreePBX will generally follow the asterisk rules for the language of the channel you have set, i.e. if you have the file in /var/lib/asterisk/sounds/gr/* it will use it, if there is none usable it will go look to /var/lib/asterisk/sounds/en/* (and eventually /var/lib/asterisk/sounds/*)


(Floe Hetling) #8

If noting else helps to resolve this issue - then I suppose you are having non-standard setup like asterisk from repo + freepbx from repo or even using FPBX on Ubuntu/different OS

Asterisk tries to read your language sounds from /usr/share/asterisk/sounds

That’s it. You’d better remove that dir whatsoever and symlink it to /var/lib/asterisk/sounds
I suppose the same must be done with moh dir

My solution
sudo rm /usr/share/asterisk/sounds -rf
sudo rm /usr/share/asterisk/moh -rf
sudo ln -s /var/lib/asterisk/sounds /usr/share/asterisk/sounds
sudo ln -s /var/lib/asterisk/moh /usr/share/asterisk/moh


#9

Installing Asterisk from the Ubuntu repos will get likely get you a very old version which is in-compatible with current FreePBX, use one of the recipes in the wiki. These WILL work with your version of Ubuntu as they get Asterisk from a supported location.