SonicWALL and FreePBX


(Vt Tech) #1

I know this topic has been fully covered and I have followed the guides but still cannot figure out the problem I’m having.
All incoming and outgoing calls work fine. The only issue I have is with Follow-Me. I’m running Elastix 2.4.0 and using SonicWALL TZ 210 on SonicOS Enhanced 5.9.0.7-17o
I have other routers such as DD-WRT and the issue goes away as soon as I swap back to those but with the SonicWALL, all extensions which have Follow-Me enabled start having a 10 second delay before ringing.

eg. Extension 100 has follow me enabled on ringallv2
101 calls 100, silent for about 10 seconds then it starts ringing.
On hunt strategy, 100 will ring but then as soon as it gets to follow-me list, there’s silence again.

I don’t experience any other issues with queues, moh or other features and call quality is excellent.

Any suggestions would be much appreciated.


(Itzik) #2

Have you tried it with the lastest version of FreePBX/Asterisk?


(Lorne Gaetz) #3

Since you don’t explicitly say so, have you followed this thread: Happiness With Sonicwalls - It can happen!


(Vt Tech) #4

As i mentioned i am using SonicWALL TZ 210 on SonicOS Enhanced 5.9.0.7-17o , and in my NAT Policies i do not have the option of Disable Source Port Remap . i checked it for inbound and outbound Nat policies i just can see NAT Method option.


(Luke C) #5

I have gotten FreePBX to work behind Sonicwalls using the post @lgaetz referred to, but have seen similar issues arise like you are experiencing. Eventually got sick of messing with them and swapped them out with Watchguards.


(Itzik) #6

I’d fire up the latest version of FreePBX and Asterisk, if it’s still an issue, then I’d investigate on the Sonicwall end.


#7

I run many many FreePBX behind sonicwalls. Most important though is to have the newer SonicOS and minimum a TZ300 that you can disable source port remapping.


(system) closed #8

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.