Some problems with Schmooze Directory module

I think this is the forum to discuss it?

Anyway, this new directory program is going to be nice.
One problem we are having is this:

Multiple parties with the same last name.
The text-to-speech only reads the first name.
So, do you want John, or John, or John, or John?
And if you press 1, 2, 3, or 4 for them, it just goes back into the loop and doesn’t select anyone.

Minor problem: there is a long delay (a few seconds) when the directory app starts up.

Also, if it says, there are multiple matches, please enter more letters…

What do you type? The last name? More of the first name?
We’ve tried every combination and they all say “we’re sorry, there are no more matches”.

As far as your second question, if there are more letters:

First off right now the recording is a pretty bad recording and we plan on making a proper recording for this that is more explicit, the module is still beta…

As far as what you press, if you are at the end of the name, you can continue with a space (1 key) and then start spelling the last name. You should also be able to press # and it should list them off to you (which it sounds like you tried).

However … if the text to speech is resulting in only the first name being read out to you, then you should report a bug in trac so it can be investigated.

Beyond that - any and all feedback here is welcome so that this module can be fine tuned. There has not been a lot of feedback up to this point and clearly refining it is what we ultimately want to do.


I don’t have tts enabled on a system to test the first name only issue right now. However, I have a suspicion that could be easily tested.

Can you try applying this patch:

Index: directory.lib.php
--- directory.lib.php   (revision 9846)
+++ directory.lib.php   (working copy)
@@ -197,7 +197,7 @@
       //TODO: BUG: hardcoded to Flite, needs to either check what is there or be configurable
                        case 'tts':
-                               $ret=$this->agi->exec('Flite '.$con['name'].'|'.$keys);
+                               $ret=$this->agi->exec('Flite "'.$con['name'].'"|'.$keys);

It’s for the file in the agi-bin directory of the directory module and is automatically copied to /var/lib/asterisk/agi-bin

Please be aware not to change the permissions/ownership of the agi script or it will fail. Furthermore, keep in mind any changes you make to the copy in the /var/lib/asterisk/agi-bin directory will be over-written when you submit.


Did you find a fix for this?

Would someone point me in the direction of how to enable flite to work? We want to use text-to-speech in the directory, but it does not appear to be able to work by default… Thanks!

Has anyone ever used a SaaS like iSpeech in conjunction with pbx?
I’ve seen some implimentations of Twilio+iSpeech, but never anything with pbx