Some extentions are unable to receive calls from other extensions

Hello everyone, this is my first post on your forum, so hope I’m writing in the right place.

I have very strange problem, some of my extensions couldn’t receive calls from other extensions, when I’ll restart devices, they’re working for some time and then again, it’s impossible to call them. First I was thinking that this problem got only one person and thought that it was caused by phone, but after replacing phone and the issue didn’t solved, I started to troubleshoot and find out, that the same problem have got couple other users too (6 extensions from 62). The symptoms are the following, when someone from inside our office (all extensions are located in the same office) wants to call to his/her colleague, he dials internal (extension) number, he hears the ordinal dial tone (as if it was actually ringing) but on the other side, the destination phone doesn’t care about this and is not ringing. When I try to call to that extension while running CLI, I’m getting the same error for all problematic extensions:

WARNING[8793][C-00001912]: app_dial.c:2437 dial_exec_full: Unable to create channel of type 'SIP' (cause 20 - Subscriber absent)

OK, here is my configuration details ( I have everything configured through the web form, e.g. didn’t touch anything from the terminal):

OS version: SHMZ release 6.5 (Final)
Asterisk version: 11.20.0
FreePBX version:

Here is the result of the command - show sip peers:

localhost*CLI> sip show peers Name/username Host Dyn Forcerport Comedia ACL Port Status Description 100/100 D Yes Yes A 5062 OK (25 ms) 101/101 D Yes Yes A 5062 OK (16 ms) 102/102 D Yes Yes A 5062 OK (20 ms) 103/103 D Yes Yes A 5062 OK (70 ms) 104/104 D Yes Yes A 5062 OK (71 ms) 105/105 (Unspecified) D Yes Yes A 0 UNKNOWN 106/106 D Yes Yes A 5062 UNREACHABLE 107/107 D Yes Yes A 5060 OK (6 ms) 110/110 D Yes Yes A 5062 OK (21 ms) 111/111 D Yes Yes A 5062 OK (69 ms) 112/112 D Yes Yes A 5062 OK (16 ms) 113/113 D Yes Yes A 5062 OK (23 ms) 114/114 D Yes Yes A 5062 OK (68 ms) 115/115 D Yes Yes A 5062 OK (68 ms) 116/116 D Yes Yes A 5062 OK (70 ms) 117/117 D Yes Yes A 5062 OK (72 ms) 118/118 D Yes Yes A 5062 OK (69 ms) 120/120 D Yes Yes A 5062 OK (70 ms) 121/121 D Yes Yes A 5062 OK (69 ms) 123/123 D Yes Yes A 5062 OK (69 ms) 146/146 D Yes Yes A 5062 OK (35 ms) 147/147 D Yes Yes A 5062 OK (17 ms) 148/148 D Yes Yes A 5062 OK (90 ms) 149/149 (Unspecified) D Yes Yes A 0 UNKNOWN 150/150 D Yes Yes A 5062 OK (81 ms) 151/151 D Yes Yes A 5062 OK (68 ms) 152/152 D Yes Yes A 5080 OK (68 ms) 153/153 D Yes Yes A 5062 OK (71 ms) 154/154 D Yes Yes A 5062 OK (21 ms) 155/155 D No No A 5062 OK (21 ms) 160/160 D Yes Yes A 5062 OK (41 ms) 161/161 D Yes Yes A 5062 OK (70 ms) 162/162 D Yes Yes A 5062 OK (67 ms) 165/165 D Yes Yes A 5062 OK (21 ms) 170/170 (Unspecified) D Yes Yes A 0 UNKNOWN 172/172 D Yes Yes A 5062 OK (33 ms) 190/190 D Yes Yes A 5062 OK (18 ms) 191/191 D Yes Yes A 5062 OK (23 ms) 192/192 (Unspecified) D Yes Yes A 0 UNKNOWN 193/193 D Yes Yes A 5062 OK (23 ms) 200/200 D Yes Yes A 5062 OK (33 ms) 201/201 D Yes Yes A 5062 OK (22 ms) 202/202 D Yes Yes A 5062 OK (21 ms) 2470003-out/24700031 No No 5060 OK (1 ms) 2470004-out/24700041 No No 5060 OK (1 ms) 2470074-out/24700741 No No 5060 OK (1 ms) 2470075-out/24700751 No No 5060 OK (1 ms) 2473011-out/24730111 No No 5060 OK (1 ms) 2500070-out/25000701 No No 5060 OK (1 ms) 2500507-out/25005071 No No 5060 OK (1 ms) 300/300 D Yes Yes A 5080 OK (20 ms) 301/301 D Yes Yes A 5062 OK (82 ms) 302/302 D Yes Yes A 5065 OK (75 ms) 303/303 (Unspecified) D Yes Yes A 0 UNKNOWN 304/304 D Yes Yes A 5062 OK (21 ms) 305/305 D Yes Yes A 5063 OK (72 ms) 306/306 D Yes Yes A 5064 OK (74 ms) 307/307 D Yes Yes A 5062 OK (27 ms) 308/308 D Yes Yes A 5063 OK (69 ms) 309/309 D Yes Yes A 5060 OK (8 ms) 310/310 D Yes Yes A 5080 OK (38 ms) 311/311 D Yes Yes A 5065 OK (79 ms) 312/312 D Yes Yes A 5062 OK (22 ms) 313/313 D Yes Yes A 5062 OK (22 ms) 314/314 (Unspecified) D Yes Yes A 0 UNKNOWN 315/315 D Yes Yes A 5062 OK (28 ms) 316/316 D Yes Yes A 5064 OK (76 ms) 401/401 D Yes Yes A 5060 OK (8 ms) 501/501 D Yes Yes A 5060 OK (8 ms) 69 sip peers [Monitored: 62 online, 7 offline Unmonitored: 0 online, 0 offline]

As you can see, the extensions with problem UNKNOWN status.

This is sip show settings result:

localhost*CLI> sip show settings

Global Settings:
  UDP Bindaddress:
  TCP SIP Bindaddress:    Disabled
  TLS SIP Bindaddress:    Disabled
  Videosupport:           No
  Textsupport:            No
  Ignore SDP sess. ver.:  No
  AutoCreate Peer:        Off
  Match Auth Username:    No
  Allow unknown access:   Yes
  Allow subscriptions:    Yes
  Allow overlap dialing:  Yes
  Allow promisc. redir:   No
  Enable call counters:   No
  SIP domain support:     No
  Realm. auth:            No
  Our auth realm          asterisk
  Use domains as realms:  No
  Call to non-local dom.: Yes
  URI user is phone no:   No
  Always auth rejects:    Yes
  Direct RTP setup:       No
  User Agent:             FPBX-
  SDP Session Name:       Asterisk PBX 11.20.0
  SDP Owner Name:         root
  Reg. context:           (not set)
  Regexten on Qualify:    No
  Trust RPID:             No
  Send RPID:              No
  Legacy userfield parse: No
  Send Diversion:         Yes
  Caller ID:              Unknown
  From: Domain:
  Record SIP history:     Off
  Call Events:            On
  Auth. Failure Events:   Off
  T.38 support:           No
  T.38 EC mode:           Unknown
  T.38 MaxDtgrm:          4294967295
  SIP realtime:           Disabled
  Qualify Freq :          60000 ms
  Q.850 Reason header:    No
  Store SIP_CAUSE:        No

Network QoS Settings:
  IP ToS SIP:             CS3
  IP ToS RTP audio:       EF
  IP ToS RTP video:       AF41
  IP ToS RTP text:        CS0
  802.1p CoS SIP:         4
  802.1p CoS RTP audio:   5
  802.1p CoS RTP video:   6
  802.1p CoS RTP text:    5
  Jitterbuffer enabled:   No

Network Settings:
  SIP address remapping:  Enabled using externaddr
  Externhost:             <none>
  Externrefresh:          10

Global Signalling Settings:
  Codecs:                 (gsm|ulaw|alaw|g726)
  Codec Order:            ulaw:20,alaw:20,gsm:20,g726:20
  Relax DTMF:             No
  RFC2833 Compensation:   No
  Symmetric RTP:          Yes
  Compact SIP headers:    No
  RTP Keepalive:          0 (Disabled)
  RTP Timeout:            30
  RTP Hold Timeout:       300
  MWI NOTIFY mime type:   application/simple-message-summary
  DNS SRV lookup:         No
  Pedantic SIP support:   Yes
  Reg. min duration       60 secs
  Reg. max duration:      3600 secs
  Reg. default duration:  120 secs
  Sub. min duration       60 secs
  Sub. max duration:      3600 secs
  Outbound reg. timeout:  20 secs
  Outbound reg. attempts: 0
  Outbound reg. retry 403:0
  Notify ringing state:   Yes
    Include CID:          No
  Notify hold state:      Yes
  SIP Transfer mode:      open
  Max Call Bitrate:       384 kbps
  Auto-Framing:           No
  Outb. proxy:            <not set>
  Session Timers:         Accept
  Session Refresher:      uas
  Session Expires:        1800 secs
  Session Min-SE:         90 secs
  Timer T1:               500
  Timer T1 minimum:       100
  Timer B:                32000
  No premature media:     Yes
  Max forwards:           70

Default Settings:
  Allowed transports:     UDP
  Outbound transport:     UDP
  Context:                from-sip-external
  Record on feature:      automon
  Record off feature:     automon
  Force rport:            Yes
  DTMF:                   rfc2833
  Qualify:                0
  Keepalive:              0
  Use ClientCode:         No
  Progress inband:        Never
  Tone zone:              <Not set>
  MOH Interpret:          default
  MOH Suggest:
  Voice Mail Extension:   *97


Please If you can help me find the reason of that error message, I don’t understand why could this happen.
Thanks in advance.

What type of phones? Does this thread help:

Hi Igaetz,

First I want to thank you for such a quick reply. Damn it, you’re right, I forgot to mention my phone models, all our VoIP phones are made by Yealink, so if I understand correctly, the only way to fix it, is to downgrade the asterisk version?

I want to ask you one more question, does this version of Asterisk - 11.20 came with some update, or it was integrated with the distribution since its release? I’m asking because, I have had installed this system for more then couple of months and those issue started in last 2 weeks. So I just want to clear it for myself, did I missed something and that problem existed from the very beginning, or it was brought by some update?

Don’t know. It won’t have been part of a FreePBX Module Admin update, but may have been included in a System Admin update. Do you have System Admin updates set to run automatically?

Well, actually I don’t like any automatic updates and I’m always installing updates on any of my server manually, after couple weeks, from its publishing. After updating system, I’m checking if system works well, but as soon as I see that nothing was broken (at least it seems so :grinning: ), I’m forgetting about it. If the update is braking something, I always have backups to restore VMs to its previous state. But this bug is very specific and it took a long time to identify that we had the problem. Someone was calling to his colleague, he hears the ringing tone and no-one picks up, so eh thinks that the colleague is either busy or he’s absent. That’s it.

Anyway, I want to thank you, you really help me to clear my mind, as I didn’t change anything in my configuration last couple months, I can’t understand why it suddenly stopped working. Thanks one more time, now I’ll try to find out more about downgrading Asterisk version and how secure it’ll be for my platform.

1 Like

Are the phones that are having problems behind their own NAT firewall?

It may be a NAT timing issue. Try changing the quality frequency in the Extension Settings for the affected extensions (the ones that cannot be called) to 30 seconds instead of the default 60 seconds.

Alternatively, it could be a registration timeout issue as well. Configure the phones to re-register more often, i.e. every 30-60 seconds instead of every 5 to 10 minutes.

Hi AdHominem,

Thank for your reply. No I’m using my Yealink phones in a bridged mode, so they’re in the same subnet without NATing. I also can’t say which extensions are affected, as there’s (lets say) quite a large group of extensions (about 15 of them) and they’re randomly broken, constantly about 7-9 extensions have problem at the same time. but maybe after a half an hour, the extension with problem suddenly registered by itself, but other extensions starting not to work. So, as I say, it’s veeery strange issue.

You’re right it mostly seems that the problem is with phone registration time-out, so sometimes they’re registered, sometimes not. Though the phones always think that they’re registered and an account status is always OK and registered, but the server think in another way, by that time and extensions have UNKNOWN status.

When you suggested to decrease phone registering time, do you mean “Server Expires” parameter in an account tab? Now it’s set to 3600 (seconds I guess) is 1 hour, should I change it, or there could be any other setting?

Oh, I found “SIP Registration Retry Timer” parameter which was by default set to 30 seconds already, but for testing I changed it to 15 sec, on 2 extension which are being unregistered most often, I also changed “Qualify Frequency” to 30 seconds on those extensions. So let’s see if it’ll help.

I don’t know what the proper settings are on Yealink phones. If some phones work fine and others don’t, and they’re all configured the same with the same extension settings, I’m less inclined to believe that its an issue with the configuration.

You may also have a hardware problem with your network. Check the cabling and switch that connects that group of phones.

In order to help diagnose this, I’d try moving the phones that don’t work to locations that do work and vice versa. If the problem follows the location, rather than the physical phone, that strongly suggests a hardware problem on the network, either with wiring, cables, or the switch.

Yesterday I tried to decrease both values that you’ve suggested me for 2 extensions/phones, but after restarting devices, they works for a while and then both stopped working :frowning:

So, you’re telling that there is nothing wrong with Asterisk version 11.20 and I have the local problem? :confused:

You see, I’ve already tried to swap non-working/problematic device with the new one, but the issue had arose again, So I really don’t know what to do. I also searched for manually downgrade Asterisk version on FreePBX but as I understand, there no official/supported/recommended steps. As official scripts for FreePBX version updates are one way and they can’t be rolled back (only restore backed up version of machine). but as we identified the issue too late, I have no idea which backup should I restore.

If the problem only started after an upgrade, I’d suspect that something went wrong with the update and you should downgrade or reinstall.

When you swapped devices, did the problem follow the device or the physical location? If it followed the physical location, I suspect a network hardware problem. If it followed the extension #, then I suspect a problem with your software.


Has anyone nailed this one down yet? I’m seeing the same thing with Yealink T46G phones. It only is happening to one phone, but moving it and swaping out the phone haven’t really given any clues? After watching the traffic for a while I can see the phone registers, asterisk stops sending OPTIONS request at exactly the 10min mark, and the phone reregisters at exactly the 20min mark.


One other thing… the phone always responds to the OPTIONS requests (and other requests) immediately with status 200. Asterisk just stops sending OPTIONS after 10 minutes.

Asterisk bug:

The correct solution is to downgrade to Asterisk 11.19.1.

No. That is not. The fixed version of asterisk is out

In that case, another solution is to upgrade to Asterisk 11.21. :slight_smile:

Thanks for the info guys! …how about for Asterisk 13 (I’m running 13.6.0)?

Both new versions of Asterisk were released last Friday