FreePBX | Register | Issues | Wiki | Portal | Support

[SOLVED] Upgrading Releases


(Ralph Streb) #1

Hello,

I am currently using:

Current PBX Version:
14.0.1beta12
Current System Version:
12.7.3-1703-3.sng7

I am trying to update/upgrade to the latest beta version to run the module upgrades. However, I was wondering if there was a way to update this without reinstalling the entire system?


(Bryan Walters) #2

If you are already running SNG7 you can run yum update on the command line (this doesn’t update your FreePBX modules) to update the operating system or go to Module Admin to see the operating system upgrades as well as the FreePBX modules.


(Ralph Streb) #3

I ran the upgrade, and thought that would update my version, however the version listed above didn’t change. Is there a way to verify my version outside of the GUI?


(Andrew Nagy) #4

What you have is the latest.


(Ralph Streb) #5

I am receiving this error when trying to run Module Updates, so I updated the system with yum update, I don’t want to reinstall my system hence the reason for this post:

Errors with selection:

Calendar cannot be upgraded:
    FreePBX version 14.0.1beta19 or higher is required, you have 14.0.1beta12
Please try again after the dependencies have been installed.
Presence State cannot be upgraded:
    FreePBX version 14.0.1rc1.2 or higher is required, you have 14.0.1beta12
Please try again after the dependencies have been installed.
Phone Apps cannot be upgraded:
    The Module Named "pm2" is required.
Please try again after the dependencies have been installed.
Sound Languages cannot be upgraded:
    FreePBX version 14.0.1rc1.2 or higher is required, you have 14.0.1beta12
Please try again after the dependencies have been installed.
Time Conditions cannot be upgraded:
    Calendar module version 14.0.1alpha6 or higher is required, you have 14.0.1alpha2
Please try again after the dependencies have been installed.
User Control Panel cannot be upgraded:
    FreePBX version 14.0.1rc1.2 or higher is required, you have 14.0.1beta12
Please try again after the dependencies have been installed.
User Management cannot be upgraded:
    FreePBX version 14.0.1rc1.2 or higher is required, you have 14.0.1beta12
Please try again after the dependencies have been installed.
Queues Pro cannot be upgraded:
    The Module Named "pm2" is required.
Please try again after the dependencies have been installed.

(Ralph Streb) #6

My apologies. After continuing with the update, it started resolving dependencies, and re-rerunning the updates allowed for the modules above to be updated.