FreePBX | Register | Issues | Wiki | Portal | Support

(SOLVED) Unknown Error (Permission Denied) Fax Pro Module


(Krystyna) #1

Hello!

I have correctly authenticated my server for Commercial Modules with FreePBX. I had purchased both Fax Pro and Conference Pro.

I have created the following:

- Inbound DID with the settings below:
----- Detect Faxes: Yes
----- Fax Detextion Type: Dahdi
----- Fax Detection Time: 5
----- Fax Destination > Fax Recipient: Extension 2300
----- Set Destination > Fax Recipient: Extension 2300

- Fax Extension with the fax setting mentioned:
----- Fax: Enabled
----- Fax Email: myemail@gmail.com (I can successfully receieve emails from FreePBX and the server)
----- Attachment Format: Both (I am testing with a simple, one page PDF, black and white)
----- Store Locally: Unchecked
----- Outgoing Station ID: The aforementioned DID number
----- Outgoing Header: My company name
----- Coversheet Name: My company name
----- Coversheet Tell: The aforementioned DID number
----- Coversheet Email: myemail@gmail.com
----- Email Results: Global Settings
----- Retries: Global Settings

Whenever I try to send an outbound fax to I receieve the following error in a green, rounded rectangle on the right hand side in the User Panel:

Gathering information...
Unknown error (Permission denied)
Unknown error (Permission denied)
Unknown error (Permission denied)
Unknown error (Permission denied)

There is no activity on the Asterisk CLI as I click the button, however, I receive system emails stating that the fax failed, and it states the following:

Sent to 4164971919
Status: Unknown error (Permission denied)
At: Sat, 26 Jul 2014 17:30:18 -0400
On: mycompany domain
For extension: 2300

If you could let me know where I am going wrong, or where I should start looking, I would greatly appreciate it!

Thank you!

P.S- I am able to send a traditional fax through the same server using a T.38 enabled adapter to send and receive faxes successfully, and I am able to send a fax to the same fax recipient/extension and receive it in my Gmail account successfully.


[SOLVED] Could not find file to send - Fax Pro
(Andrew Nagy) #2

Versions would be a fantastic thing to have here


(Krystyna) #3

I apologize! Totally forgot!

I am running the FreePBX Distro FreePBX-5.211.65-14-x86_64-Full-1402716429, so that would be:

Asterisk 11.10.2
FreePBX 2.11.0.38

Please let me know if you need any more information from me please :slight_smile:

Thank you for the assistance!


(Krystyna) #4

Hi,

This is a bump… not exactly sure where to go from here as I can’t find this error in Google or on the FreePBX forums.

Thanks,


Fax Pro - Permission Denied
(Krystyna) #5

Ok, an update.

I’m going to mark this post as SOLVED as I found out what the issue was. I had incorrect credentials in the manager.conf file. This is what was giving me the “Unknown Error (Permission denied)” error. After I fixed the username in my manager.conf file, I was then able to send PDF files to my FoIP install at my house (working from the office today, very rare).

Also, I added a prefix on the “Global Fax Prefix” setting, as well as created an outbound route directly to my provider with the same prefix so that I have a dedicated prefix and outbound route just for faxing.

Thank you to all who helped me out!! I really REALLY appreciate it!!


(Andrew Nagy) #6

Cryptic develop errors messages are never helpful (think PC load letter). Glad you got it figured out!


(Krystyna) #7

Lol :smiley:
My sentiments exactly with this whole situation!!


(Adel Elmenyawy) #8

Hi Krystyna,
Could you please share what have you done here to fix it?
Thanks,


(Dave Burgess) #9

I’m pretty sure he did.


(Andrew Nagy) closed #10