[SOLVED ]Unable to install mod_ssl

I’m trying to setup https through the system admin menu. I generate the self signed certificate, then go to the settings tab to install it. There it says:
mod_ssl not installed Unable to proceed! Run yum install mod_ssl as root to continue.

So I SSH into the machine as root like it says and run the yum install mod_ssl and get this error:

http://yum.freepbxdistro.org/pbx/6.12.65/x86_64/RPMS/httpd/2.2.15/mod_ssl-2.2.15-31.shmz65.2.8.x86_64.rpm: [Errno 14] PYCURL ERROR 22 - "The requested URL returned error: 404 Not Found"
Trying other mirror.

Error Downloading Packages:
1:mod_ssl-2.2.15-31.shmz65.2.8.x86_64: failure: RPMS/httpd/2.2.15/mod_ssl-2.2.15-31.shmz65.2.8.x86_64.rpm from pbx: [Errno 256] No more mirrors to try.

I am running the latest stable distro: 6.12.65-30.

Looks to me like the repo is missing a package. Any help will be greatly apprecaited. Thanks!


yum cleanall

then try again

Well that was almost too easy. Worked like a charm. Thanks for the super quick reply!

1 Like