[SOLVED] Trying to provision Yealink W60B and 5 W56H handsets

I have tried with zero success to provision 5 x W56H handsets via a W60B base station. It must be something I am missing in all the researched articles that I have found and therefore time to ask for an “idiots guide” on how to accomplish this.

I have tried using EPM and provisioning manually, I would prefer the former if at all possible.
I have tried after doing a factory reset on the W56H’s and the W60B.

I am using:
Asterisk 16.3.0
Endpoint Manager (commercial)
All firmware in the W60B and W56H’s are the latest versions.

I have provisioned some 50 Yealink T46S handsets using EPM with great success.
When I connect the W60B, I do a network scan in EPM and find the W60B but that is clearly not of much use.
I have manually registered the handsets in the W60B but cannot see them in EPM. I have tried setting the server url in the W60B but no change.

If the W60B needs to be configured as a Base Station in EPM I can see no way to do this as there is no associated template.

ANY assistance would be appreciated and may go some way to restoring my (in)sanity!

Anyone got Yealink DECT phones working with Freepbx?

Never tried to do it with EPM. I expect it won’t work ever.

DECT phones don’t work the same as a normal phone.

I would just set up a config file manually for these.

Thanks sorvani.
Begs the question … why is W60B available in the EPM yealink template “Available Phones”.
However I suspect you are right!
Hope I can remember how to manually configure a phone :slight_smile:

I have 2 sets of Yealink W52P provisioned in my system, and i have to admit It was complete pain in the ****!
Basically i have spent few days trying EPM plus Yealink forwarding services that worked perfectly on the T2 and T4 series. ( So save your energy it didnt work)
The only way i managed to get them provisioned is manually using the web page of the Yealink.
First factory defaults! then i have set the correct time zone and NTP servers and saved.
Then in the “Auto Provision” section i had to input (i can’t recall which worked its been a while)
Server URL: tftp:tftpuser:[email protected]:tftpport OR The same but using HTTPS i know i had to play with this configurations almost hundred times! definitely only one will work!
Then again user in the user section and pass in the pass section.
then click auto provision now and give it few min. i remember it was delayed.

Since both phones working perfect for over a year now in a restaurant.
Sorry if i’m a bit all over but that the best my memory would do.
Good Luck.

I am sure at a basic level EPM works for it.

As sorvani said… but in this case W60B in EPM is a little too basic to be useful :frowning:
YoniNVG: Thanks for the input - looks like your way is the only way! If I get the stuff integrated/working I’ll post how I did it here; hopefully soon!!

Thanks again for looking at this issue for me and any other ideas MORE than welcome.

DONE IT!!! You were correct - forget EPM for DECT phones (can’t speak for Sangoma in this regard).
I will document over the next few days. If anyone has an urgent need for Yealink DECT setup let me know.

1 Like

I actually have to provision around 20 Yealink W56P in June. Any chance that you give me a quick heads up on the settings you used?

Hi Badmin, I am on the road until mid next week but I notice you have a few weeks until you need my information.
I will get it done next week and attach it to this thread. Once the initial setup of the base station is done - about 20 minutes with my typingggg, each phone takes about 7 minutes to complete. Have to be provisioned 1 at a time unfortunately.
You will need the extensions created in Freepbx before you start.
I used both http and https for provisioning with authentication - both worked fine.
I tried with extensions configured with chan-sip and PJSIP - both worked fine. I think PJSIP is the preferable way as it provides for more functionality.
I also setup a couple of the phones to use the same extension as a users desk phone and that went fine as well. In other words ring their extension and both the W56H and T46S ring simultaneously.
Hope this helps for few days.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.