[SOLVED] SIPstation and error WARNING The server is currently not responding


(Nevada Tech) #1

Hello,

I have a clean install of FreePBX 2002.02 It’s working fine except for sening/receiving calls. Mainly, I’m trying use SIPstation SIP service. When I look at the Connectivity> SIPstation I get:

WARNING The server is currently not responding. It is either unavailable or access is being blocked. If the server is unavailable, please try again later.

I submitted a ticket to SIPstation and received this response:

Your firewall is not allowing traffic back from push2.schmoozecomcom and that is what is required for the module to show proper status. Currently I show you registered to trunk1 but there is a problem because the port is being translated. You need to set your firewall to not translate the port of traffic from your PBX to our trunking servers.

So, how do I fix this? Some of my testing has been to place the server on the Internet with its own public IP (same error) and the FreePBX firewall enable; I’ve built a clean PBX and placed it behind a pfSense router in it’s own DMZ and open the ports (5060 TCP/UDP and 10000-20000 UDP) + tried 1:1 NAT + tried port forwarding (same error).

Initially I though it was a pfSense issue but putting it flat on the Internet excluded that culprit. I don’t see in the FreePBX Firewall how to set ports or NAT’ing. Using the GUI first and then fwconsole to make sure trunk1/trunk2.freepbxcom and push2.schmoozecomcom were Trusted and exclude from firewall does not change the error message. FYI, I know the trusted should be .com but this generates a forum pasting error.

If I delete the key the SIPstation module comes the page renders properly, until I re-add my key.

So what obvious thing am I missing? Thanks!


(Dave Burgess) #2

Excuse me, but that seems like it might be a little out of date.

What version of FreePBX and Asterisk are you actually running?

The response from support seems about right. Your firewall seems to be getting in the way of your success, so you’re going to need to tell us more about your firewall.


(Lorne Gaetz) #3

@cynjut check the distro downloads page, you will see 2002 (Feb 2020) is current.


(Nevada Tech) #4

More details…

When I used pfSense I completely turned off the FreePBX firewall. My hope was that I could better manage the firewall/NAT/porting through pfSense

The install is current stable with FreePBX 15, Linux 7.6, and Asterisk 16. All modules are updated and the OS itself is fully updated.

At one point with the PBX on the public IP/Internet (no router) I even tried turning off the firewall there. SIPstation service still fails. What would be doing translating (per SIPstation support) at this point? Just for new peeps - this is a very bad idea for production but this was a test and my plan is to wipe the box and re-install once I know how to fix the problem.


(Nevada Tech) #5

Can anyone definitively say what eth0 should be set as? I think it should be set to Internet since it is directly connected to the Internet (no router in front of it). Am I interpreting it wrong? Should it be Trusted or Local?


(Nevada Tech) #6

Since I had some time to kill I re-installed with FreePBX 1904 (Asterisk 13 and FreePBX 14). Updated the OS and FreePBX, added the SIPstation key - same exact issue.

My next test was to move the trunk1/trunk2/push2 over to Internet firewall zone, reboot to make sure I get a clean response - same failure.


(Nevada Tech) #7

It was a SIPstation issue. Initially I tried setting up the PBX at location1 (test network) with a SIPstation key and it failed. I moved it to location2 (final destination) and after a couple rebuilds, with and without firewall, in a DMZ, straight on the Internet, it continue to fail.

I received a 2nd response and
SIPstation: That’s odd we see you registered fine at public IP location1, with some crazy port redirection
Me: But I’m at location2, is there any way to re-register/de-register?
SIPstation: Go to My Account> Trunk Group> Notification and Access Control Panel> enter in your new public IP

And now things are happy happy.

Remember you can’t see where your SIPstation account is registered, but you can add your known public IP to the ACP.


(system) closed #8

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.