[SOLVED] Remote extension, one-way audio on sip client

Hi all, I am new in this community and in pbx too.
I have successfully installed and configured a freepbx, added a trunk (chan sip), added inbound and outbound routing and all works very well on LAN: calling the VOIP number configured on the trunk will transfer the call to one extension, this extension is on the same LAN of freepbx and the audio is ok in both directions. The client is using Linphone desktop, v 4.1.
The problem is that we have to provide this functionality to other collegues that are out of the office, so we provide them other extensions but in this case something went wrong with the audio of the call.
The client can’t hear nothing, the caller can hear the client. One way audio.
We have tried several SIP client but the problem is the same. Only using Zoiper 5 we can have a call with an extension out of our LAN.
So we checked all the configuration and we find out that Zoiper uses default STUN server (stun[.]zoiper[.]com) and Linphone not. So, we add a STUN server in Linphone config but nothing changed.

We could use Zoiper 5 for external collegues but in free version Zoiper 5 hasn’t call transfer and some other interesting features (that Linphone has), so: am I missing something? have I misconfigured something on asterisk/freepbx (although the call was ok with Zoiper 5)?


If you can’t find a better solution, you should be able to transfer calls from free Zoiper by dialing ## (blind transfer) or *2 (attended transfer).

A remote extension rarely requires STUN, typically in cases where it is behind a restrictive firewall and the user does not have admin rights to it.

Do you mean that some remote extensions work fine with Linphone but one is failing? Or, does Linphone not work at all when remote?

Are the remote extensions pjsip or chan_sip? Have you tried the other?

Thanks Stewart!
I really like Zoiper 5 but it’s really annoying if you haven’t turned it pro. On startup it won’t connect automatically and it’s full of stickers that reminds you to turn it pro. Not the best if you are in professional environment…
In case I can’t configure Linphone I will follow you suggestion (blind and attended transfer).

I wrote about STUN because I tested both Zoiper and Linphone on the same client and the only difference was the use of STUN server by Zoiper. I tried to deactivate STUN server on Zoiper and the result was the same as with Linphone: one way audio. So I get convinced that the problem was STUN server.
Furthermore, the remote clients are on their home private network, under their commercial routers. I don’t think they are so restrictive but I can’t ask to shut down home firewall to get connected with SIP client.

No: the same extension works with Zoiper but doesn’t work with Linphone.
Yes: Linphone doesn’t work at all when remote. Only one way audio. But works well when in LAN

I sniffed packets (on the client when remote) with wireshark, filtering RCP packets and when using Zoiper I can clearly see two way RCP streams (from client to server and from server to client). When using Linphone I can only see one way RCP stream (from client to server).

The remote extension are chan_sip
No, I haven’t tried other kind of extension.

Confirm that in Asterisk SIP Settings, External Address and Local Networks are correctly set. If you change these, you must restart (not just reload) Asterisk.

For the extension in question, Confirm that NAT Mode is set to Yes.

If you still have trouble, at the Asterisk command prompt, type
sip set debug peer 1234
(replace 1234 with the extension number of the Linphone user, with Linphone configured without STUN) then make a test call that fails with one-way audio. Paste the relevant section of the Asterisk log at https://pastebin.freepbx.org and post the link here.

Stewart you save my day (days)!
I checked all settings on clients but not on freepbx.
The game changing setting was to enable NAT Mode -> Yes (force_rport,comedia) on single extension per each extension.
Now the extension works well both in LAN and on remote with Linphone.

I will change the title in [SOLVED]

Thank you

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.