[SOLVED] Problems with ARI in FreePBX 15


I’ve just set up a FreePBX 15 from scratch and enabled ARI Rest Services through the Admin Panel.
But when i type: http show status, I get the following output:

HTTP Server Status:
Server: Asterisk/16.2.0
Server Enabled and Bound to
HTTPS Server Enabled and Bound to
Enabled URI's:
/httpstatus => Asterisk HTTP General Status
/static/... => Asterisk HTTP Static Delivery
/ws => Asterisk HTTP WebSocket
Enabled Redirects:

The /ari endpoint is not there for some reason. This is my configuration as of right now:

Anyone has any thoughts?

Kind regards,

fwconsole ma downloadinstall arimanager
fwconsole reload
fwconsole restart

In the first command I already get:

No repos specified, using: [standard,unsupported,extended,commercial] from last GUI settings
Downloading module 'ari'
The following error(s) occured:
 - Array
 - Array
 - Retrieved Module XML Was Empty

It seems like your system is out of date. Have you upgrading everything?

I’m using FreePBX
And all models that comes with default are upgraded. Should I install others?


Maybe you need to use freepbx 14 instead. You have weird errors on module installation.

Ok. I will try to downgrade over here.

I’ve downgraded and it worked not by the GUI unfortunately but installing arimanager using your command. It worked.
I saw that you have edited the post from ari to arimanager.
Well I will try on version 15 as well. Maybe it works.

Thank for the help @tm1000

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.