[SOLVED] Problems registering a deployment

Arch = x86_64
OS = CentOS6.3 (freepbx)
FreePBX =

It appears that there is some delay in obtaining a registration and it appears that one must manually reload the license page in FreePBX in order to display the system registration.

Original Post below:

I have tried to register my FreePBX distro on Schmooz3e.com to obtain commercial modules. However, I kept getting an error whenever I tried to do this from within FreePBX. So I went to portal.schmoozecom.com an registered. There I discovered they I was already registered (in consequence of having attended a course) which accounted for the errors (so I thought).

I therefore changed my password and then attempted again to register my deployment from the freePBX GUI. Still another error. I then returned to Schmooze.com and looked at my registration list and behold, every single one of the ‘failed’ deployment registrations were in fact on file.

I then picked the one which had the most complete information and returned to the FreePBX GUI and attempted to use that deployment ID to register the system. This failed as well but it did add yet another deployment ID to the list associated with my account.

How do I get one deployment ID associated with my single FreePBX installation?