[SOLVED] Problems installing languages "I noticed that several people online have the same problem"


(Claudio Pelosi) #1

Going to the sound language menu and trying to install Italian gives me this error:

SQLSTATE[22001]: String data, right truncated: 1406 Data too long for column ‘filename’ at row 1
File:/var/www/html/admin/modules/soundlang/Soundlang.class.php:1125

I am a little confused someone can tell me how to solve

FreePBX is new … recently installed

FreePBX version 15.0.16.38 with all updated modules


(Claudio Pelosi) #2

I searched online and there seem to be several people who have the same problem … But I still haven’t found anyone who has solved it

Here is a site that presents the same situation:
http://www.asterisk-italia.it/forum/viewtopic.php?f=1&t=4496


(Lorne Gaetz) #3

Works for me on sound languages ver. 15.0.5.6. What is the output from:

fwconsole ma list | grep soundlang

(Claudio Pelosi) #4

root@raspbx:~# fwconsole ma list | grep soundlang
| soundlang | 15.0.5.6 | Attivato | GPLv3+ |


(Claudio Pelosi) #5

have you tried with Italian?


(Lorne Gaetz) #6

Yes. Works fine:


(Claudio Pelosi) #7

(Claudio Pelosi) #8

Here I filmed the error


(Claudio Pelosi) #9

Important update: I tried Spanish and with Spanish it works and also with other languages
So the error is only present with Italian


(Claudio Pelosi) #10

I solved … but … I solved how I do not like …
I went to see the code and consequently understanding what is wrong I lengthened the size of the filename field of the soundlang_prompts table from 80 to 255

Now the Italian also installs the Italian but I think it’s a bug …

Wouldn’t it be better to report it to fix …?


(Lorne Gaetz) #11

Yes.

edit - ticket is here: https://issues.freepbx.org/browse/FREEPBX-20981


(F4lk3n) #12

can you describe the steps taken?
I have the same problem and I don’t know where to change the parameters to correct it


(Itzik) #13

If you look at the ticket you’ll see that a dev asked @claloano as well, but no answer so far.


(Claudio Pelosi) #14

In order to solve it you have to go to the asterisk database in the soundlang_prompts table and increase the size of the filename field to 255


(system) closed #15

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.