Solved: PJSIP Trunks stopped working after reboot


(Dave) #1

Running FreePBX 14.0.13.6

My Freepbx server hadn’t been restarted for just over a year (probably a mistake to have left it that long).

The config is pretty simple, some pjsip extensions and a couple of Grandstream FXO gateways to connect them to our analogue PABX. Each port on the gateways is setup as a PJSIP trunk. All of this has been running perfectly.

I needed to add another PJSIP trunk but after doing so couldn’t get it to work and noticed that the asterisk console log was showing messages “Identify section trunkname points to endpoint trunkname but endpoint could not be looked up”

“pjsip show endpoints” listed all of the pjsip extensions and existing trunks setup for the gateways but not the new trunk. I couldn’t find any combination of settings for the new trunk that would end up with an endpoint being created.

After some head banging, I rebooted the server. The server restarted but wasn’t contactable. Logging in to the virtual machine console showed that it had picked up a dhcp address after the reboot. I logged in to the freepbx web page using the displayed ip and in Network settings it was now displaying the dhcp address instead of the static ip the server had been configured with. I reset the ip address and extensions were registering again.

At this point all seemed well but now no extensions were able to call via the gateways. Looking at the asterisk console there were now the “Identify section … endpoint could not be looked up” messages for all of the pjsip trunks for the gateways. Using “psjip show endpoints” only displayed entries for the extensions, no trunks at all.

I’ve tried fwconsole chown and rebooting but no change. I tried recreating a trunk but still no endpoint is created.

So, the pbx is out of service until I can sort this out, any ideas on where I can look to see why the endpoints aren’t being created?

Edit - removed unintended formating


(Dave) #2

I wasn’t able to work out why this event occurred but after restoring from a backup the trunks connectivity was restored. The server was still displaying both the static and a dhcp IP address on the console login screen but after changing the static ip through the gui a couple of times it also reverted to showing ( and responding) to just the static IP. A newly created pjsip trunk also worked normally.


(system) closed #3

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.