FreePBX | Register | Issues | Wiki | Portal | Support

[SOLVED] Phone Apps with Sangoma Phones


#1

Hello,

I am just doing a FreePBX Distro deployment with just Sangoma phones. I assigned the “sangoma_default” template to a phone I am testing with (S405), and it comes up fine (I can make/receive calls), however all the apps I try get a message on the screen that says “Failed to load XML”.

When I look in the Apache “access.log” I see either a 404 error or a 500 error (depends on if I am using Distro 13 or 14 – I tried both, in case it was a distro-specific issue)

Firmware on the phone is 2.0.4.43.

When I look under “Line Keys” on the phone, I see entries like the following (URL domain changed for privacy purposes):

http://pbx.clientdomain.com:84/applications.php/restapps/main?user=999

and as I mentioned earlier, I can see hits in “access.log” when I press the keys but they result in either 404 or 500 errors.

The https://wiki.freepbx.org/display/PHON/Enabling+Phone+Apps+on+a+Sangoma+Phone page states:

If you are using a Sangoma s400, s500 or s700 phone you will not need to purchase the Phone Apps module or End Point Manager Module as these modules will work with Sangoma Phones out of the box with no license purchasing needed.

(Since the page was last updated in Dec 2015, I am assuming this applied to the S405 models as well, as the S405 came out after Dec 2015)

In “User Management” under the Groups, I don’t see anything about the access to the Phone Apps, but since I don’t have the Phone Apps module, I wouldn’t expect to (Phone Apps are supposed to be included with Sangoma phones, no?)

Please advise. Thanks! :slight_smile:


#2

OK, I might have figured it out. The “Phone Apps” module was disabled pending an upgrade to much newer version. I selected the option to upgrade and enable it.

Unfortunately, I am not at the office where my test phone is, but I will by stopping by there tomorrow to pick up a few things for Monday and will give it a test to see if that’s the issue.

I will update this thread either way.


(Tony Lewis) #3

That would be your problem. You still need the module installed you just don’t have to buy a license for it when using Sangoma phones.


#4

Just to confirm, the “Phone Apps” module being disabled is indeed what the issue was. I was able to use the Phone Apps on the Sangoma phone no problem when I went into the office.


(system) closed #5

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.