[SOLVED ]Parking lot BLF shows amber (orange) light although it functions properly. Should be GREEN

There were two changes made to my Freepbx server before the problem occurred.

  1. I updated all modules

  2. I changed my ethos setting in firewall from Trusted all all to Internet

Now, all my BLF keys for the parking lot changed from green to yellow, yet they still function properly

Any help in this area would be appreciated.

Asterisk hints can be “In Use” or “Idle”, it is up to the phone firmware to determine how to display the hint. There is nothing in Asterisk that says ‘Display BLF buttons as yellow’.

I have Freepbx 13. There is an option under the Parking module to select BLF hints ENABLE or DISABLE. I choose ENABLE and it highlights blue to let me know it is selected. Then when I click save it goes back to where it was as unselected. I won’t allow me to choose enable under blf hints

AS you can see, under BLF capabilities (parking lot pro) it wont let me select enable.

The “amber” colored key is my “parked” call - it should be green. It functions properly, but the color won’t go back to green. It went amber after I did a module upgrade

The BLF key is configured like this:

fnc=blf+sd+cp;[email protected]$PROXY

50 is the parking lot and 51 is one of the slots.

It was green up until 3 days ago when I did the module upgradedes

I use parking lot pro

Any help on this issue would be greatly appreciated

That setting has no bearing on anything. In fact it should have been removed. Not sure what version of anything you are running.

Why can’t I choose ENABLE in parking lot pro for BLF Capabilities? When I click on the button that says ENABLE, it highlights like it selects, but when I hit the submit button it greys back out and never actually selects

That sounds like a bug in the parking module. That has nothing to do with Park Pro. That feature is part of Park. Have you verified you have all updates modules.

Setting doesn’t matter anyways. It’s always enabled.

What versions of park and parkpro are you using? The latest version doesn’t have the “BLF Capabilities” option in the GUI.

1 Like

I think the developers need to address this bug in parking lot pro. The issue did not arise until I did a module update and one of the modules updated was parking pro. My issue still exists.

Some notes on this issue:

The issue is on CISCO SPA 504G

This is the function code I am using to monitor parking slot 51

fnc=blf+sd+cp;[email protected]$PROXY

Parking lot Pro Version: 13.0.23

Current edge versions of parking modules:

# fwconsole ma list | grep park
| parking              | 13.0.19.6   | Enabled                           | GPLv3+     |
| parkpro              | 13.0.30.9   | Enabled                           | Commercial |

Your park pro module is out of date. If you are not being presented with updates, it could be your maintenance period has elapsed and needs to be renewed.
https://wiki.freepbx.org/display/FPAS/How+to+Renew+Commercial+Modules+from+the+Portal

This issue is resolved. Let me share . . .

I thought a 25 yr license on a module meant 25 years of updates too. I didn’t realize I had to update it as well. All is working well now.

Thank you to all those that helped!!

1 Like