[SOLVED] No such command 'sip show peers'


(HawkEye) #1

Hi, this is strange. Ran asterisk-version-switch on FreePBX 14.0.13.12 to go to Asterisk 16. After it completes, tried to run:
*CLI> sip show peers
No such command ‘sip show peers’ (type ‘core show help sip show’ for other possible commands)

*CLI> module show like sip
Module Description Use Count Status Support Level
0 modules loaded

*CLI> pjsip show endpoints
No such command ‘pjsip show endpoints’ (type ‘core show help pjsip show’ for other possible commands)

Tried asterisk-version-switch and went back to 13. The same thing as above. No sip, no pjsip

rasterisk

Connected to Asterisk 13.27.1

*CLI> module show
Module Description Use Count Status Support Level
app_dahdiras.so DAHDI ISDN Remote Access Server 0 Running extended
app_flash.so Flash channel application 0 Running core
app_flite.so Flite TTS Interface 0 Running unknown
app_meetme.so MeetMe conference bridge 0 Running extended
app_mysql.so Simple Mysql Interface 0 Running deprecated
app_page.so Page Multiple Phones 0 Running core
app_voicemail.so Comedian Mail (Voicemail System) 0 Running core
cdr_adaptive_odbc.so Adaptive ODBC CDR backend 0 Running core
cdr_odbc.so ODBC CDR Backend 0 Not Running extended
cel_odbc.so ODBC CEL backend 0 Running core
chan_dahdi.so DAHDI Telephony w/PRI & SS7 & MFC/R2 0 Running core
chan_mobile.so Bluetooth Mobile Device Channel Driver 0 Not Running extended
chan_ooh323.so Objective Systems H323 Channel 0 Not Running extended
codec_ast13_g729.so g729 Coder/Decoder, based on Intel IPP 0 Running unknown
codec_dahdi.so Generic DAHDI Transcoder Codec Translato 0 Running core
codec_resample.so SLIN Resampling Codec 0 Running core
format_mp3.so MP3 format [Any rate but 8000hz mono is 0 Running extended
format_ogg_vorbis.so OGG/Vorbis audio 0 Running core
func_curl.so Load external URL 0 Running core
res_config_curl.so Realtime Curl configuration 0 Running core
res_config_mysql.so MySQL RealTime Configuration Driver 0 Running extended
res_config_odbc.so Realtime ODBC configuration 0 Running core
res_curl.so cURL Resource Module 0 Running core
res_odbc.so ODBC resource 0 Running core
res_timing_dahdi.so DAHDI Timing Interface 0 Not Running core
25 modules loaded

Many modules are simply not installed.
Any idea how to get this working again?
Thanks.


(Tom Ray) #2

Did you try restarting Asterisk after this again? Or did you try loading the modules that aren’t loaded like “module load chan_sip.so” and see what happens?


(HawkEye) #3

Fixed. Problem was flag set on one file.
Thanks.


(Franck Danard) #4

@Hawkeye. What’s the file exactly? :wink:
Please, try to bring some details on your fix for the community.


(HawkEye) #5

We use customized logrotate.d/asterisk file which gets changed automagically. The way to fix that is chattr +i. This caveat is, setting the flag will also prevent any asterisk update because when asterisk itself is updated, it moves asterisk to asterisk.rpmnew and puts in a default asterisk.

Hope this clears your question.


(Franck Danard) #6

Thanks so much :slight_smile:


(HawkEye) #7

Actually, another FreePBX 14 server (14.0.13.12) we ran asterisk-version-switch on and chose asterisk16. Does almost same thing. In CLI> commands work however while calls come in and go out, there is nothing displayed in CLI> . Have sip debug at 10 and pjsip logger on. Also tried rtp debug on and nothing in CLI>.

Have other PBX’s with a version of Asterisk16 which work just fine. Just one pbx is not able to run 16. No clue yet as to why.


(Franck Danard) #8

Do you have any PCI cards with E1, FXO, FXS …Etc
Or have you got something of specific (custom asterisk library / module) compiled in Asterisk 13 and not in 16?


(Tom Ray) #9

@danardf Just save yourself the trouble and stop here. You won’t get straight answers. We dealt with this in IRC yesterday. What is missing here is the fact this was first presented as a one-way audio issue and then the claim was no RTP could be see flowing through the PBX. Followed by how nothing is showing up in the CLI but calls are working.

So first we double checked that the OP was in the right PBX because the OP has a history of doing something like this and then saying “Opps, I was in the wrong PBX” while doing troubleshooting. Then while multiple people were trying to get more information and offer up suggestions the OP just said “I’m switching them back to 13. Oh it worked. I’m done” and left it at that.

ZERO troubleshooting or efforts to do any level of troubleshooting outside of turning on some basic Asterisk debugs. No tcpdump, no sngrep, nothing to prove that traffic was hitting the PBX. No ‘fwconsole chown’ or ‘fwconsole restart’ just to make sure ownership and permissions were correct or things were restarted properly and in proper order.

Also no confirmation that this system isn’t the same system that this thread was started about and that switching to Asterisk 16 was messed up due to files being chattr +i on the system.

Oh and as well as a history of doing things in the wrong PBX, the OP also has a history of making modifications to a PBX and then forgetting about them and after hours of working on something remember “Oh yeah I did this” and then the problem is fixed.


(HawkEye) #10

Franck, no there are no PCI cards whatsoever. As mentioned, not sure why this one FreePBX Server exhibits this behavior. We have several other FreePBX severs running Asterisk 16.x.x and they don’t have any issue at all.

In as far as any custom, the only customization is in logrotate.d and that would not cause this issue.


(HawkEye) #11

Hi Franck, one other thing should be mentioned. When this particular FreePBX was running Asterisk 16, I called the DID on that PBX and dialed the owners extension. When the call was sent to the follow-me TN (cell phone number) there was one-way audio issue. The owner could not hear me. Repeated the call 6x and all calls were the same, having the one-way audio issue as well as nothing showing in CLI> . Did have rtp set debug on, sip set debug on, core set verbose 10.


(Franck Danard) #12

About audio issue. (a little off topic here). You may have some NAT issues or something else in your network or also some wrong settings.
Create a new thread for that. Maybe someone will help you.

About PCI, that was just to know, that’s all. I remember that i saw a kind of stuff like that one or two years ago.


(HawkEye) #13

I can’t see how there is an issue with audio when asterisk 13 is running and no one complains about audio. In this one server, install 16, dial company TN, dial extension, follow-me kicks in, the one-way audio is present.


(Tom Ray) #14

Do they have call confirm enabled for this? Do they have to press 1? If not enable it and try again.


(system) closed #15

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.