[Solved] No Sound at all even in LAN

Hi all,

I am testing the latest distro but result in having no sound at all in any type of call even between 2 IP Phone located in the same physical network as the Freepbx machine…
This test is being performed in parallel to an existing production FreePBX server. In the same subnet, 192.168.50.0/24. The machine used for the test is a virtualbox machine, cloned from the production machine (Asterisk 1.8 with freepbx 2.11), on which I loaded the FreePBX iso and reformated the whole disk with this lastest version: the 32bit FreePbx 2.11 with Asterisk 11.2 ( Build 63-8)
I then loaded with the Back-up module the PBX config of the production server (With Asterisk 1.8)
The production server having chan_mobile and google voice I configured the chan_mobiles by hand. And the google voice by the new Motif module.
In the production server Google voice was Google talk, configured in Jabber.conf and a gtalk.conf, but configuring it in the new asterisk 11 went very fast, and it reported “Connected” instantly.

All seemed fine…

Even if the “Show peers” command showed all the prodution peers connected to the new server (???) this deseapeared after a while (the next day), and only the 4 exensions of actually connected to the test server eventually remained in the “Show Peers”

But now, those ip phones, and softphones on the new server, can call each other, they ring, but there is NO SOUND at all.
Same behaviour between 2 Ipphone, 2 softphones, or Sofphone to IpPhone.

I cannot understand why as they are in the same subnet as the server, no firewall in-between.

I can see 3 possible issues :
1 - A Codec issue with Asterisk 11
2 - A SIP Seting issue due to the Back-Up and restore that was done from an Asterisk 1.8 to an Asterisk 11
3 - the Virtual box network interface no letting RTP in or OUT.

But I looked into all 3 directions and could not find anything.

For the codec issues I only left ulaw and alaw activated in the SIP Settings to maximise compatibility, but no chance. With respect to codec I paste here my “Show translations” because they look suspicious to me: in the old server those translations time are up to 15.000 time faster !!
g723 gsm ulaw alaw g726 adpcm slin lpc10 g729 ilbc g726aal2 g722 slin16 testlaw
g723 - 15000 15000 15000 15000 15000 9000 15000 15000 15000 15000 17250 26250 15000
gsm 15000 - 15000 15000 15000 15000 9000 15000 15000 15000 15000 17250 26250 15000
ulaw 15000 15000 - 9150 15000 15000 9000 15000 15000 15000 15000 17250 26250 15000
alaw 15000 15000 9150 - 15000 15000 9000 15000 15000 15000 15000 17250 26250 15000
g726 15000 15000 15000 15000 - 15000 9000 15000 15000 15000 15000 17250 26250 15000
adpcm 15000 15000 15000 15000 15000 - 9000 15000 15000 15000 15000 17250 26250 15000
slin 6000 6000 6000 6000 6000 6000 - 6000 6000 6000 6000 8250 17250 6000
lpc10 15000 15000 15000 15000 15000 15000 9000 - 15000 15000 15000 17250 26250 15000
g729 15000 15000 15000 15000 15000 15000 9000 15000 - 15000 15000 17250 26250 15000
ilbc 15000 15000 15000 15000 15000 15000 9000 15000 15000 - 15000 17250 26250 15000
g726aal2 15000 15000 15000 15000 15000 15000 9000 15000 15000 15000 - 17250 26250 15000
g722 15600 15600 15600 15600 15600 15600 9600 15600 15600 15600 15600 - 9000 15600
slin16 21600 21600 21600 21600 21600 21600 15600 21600 21600 21600 21600 6000 - 21600
testlaw 15000 15000 15000 15000 15000 15000 9000 15000 15000 15000 15000 17250 26250 -

For the SIP Settings, I tried various options of NAT, “yes” and “no”, but no chance either. Logical as they are on the same local subnet.

For the VirtualBox settings, they are exactly the same as for the production, bridged interface with promiscuity mode set to “All allowed” I don’t know what more I can do…

Any idea anybody ? or new investigation track I could follow ?

Here is the standard log of a call that has no sound , with RTP debug LOG enabled :
11:57:32] VERBOSE[2204][C-] pbx.c: – Executing [[email protected]:42] Dial(“SIP/203-00000009”, “SIP/202,30,trwW”) in new stack
11:57:32] VERBOSE[2204][C-] netsock2.c: == Using SIP RTP TOS bits 184
11:57:32] VERBOSE[2204][C-] netsock2.c: == Using SIP RTP TOS bits 184
11:57:32] VERBOSE[2204][C-] netsock2.c: == Using SIP RTP CoS mark 5
11:57:32] VERBOSE[2204][C-] netsock2.c: == Using SIP RTP CoS mark 5
11:57:32] VERBOSE[2204][C-] app_dial.c: – Called SIP/202
11:57:32] VERBOSE[2204][C-] app_dial.c: – Called SIP/202
11:57:33] VERBOSE[2204][C-] app_dial.c: – SIP/202-0000000a is ringing
11:57:36] VERBOSE[2204][C-] app_dial.c: – SIP/202-0000000a answered SIP/203-00000009
11:57:36] VERBOSE[2204][C-] app_dial.c: – SIP/202-0000000a answered SIP/203-00000009
11:57:39] VERBOSE[2204][C-] pbx.c: – Executing [[email protected]:1] Macro(“SIP/203-00000009”, “hangupcall,”) in new stack

As you can see no RTP packet is neither entering nor leaving the server during the whole call !!

The issue was a VIRTUALBOX problem, the clone I did from the production server also copied the MAC Adress, and Two different IP Adresses with same MAC adress this generates a conflict in the same network.
So I changed the MAC adress of the network interface of the Test Server and now sounds work…
I’ll keep on trying the result of this upgrade and if new issues I’ll post new subjects.
Hope this will help someone one day, I lost a full day on this #$%&·$!#@.

bye

hi,
I installed trixbox, configured 2 extensions also sucessfully registered X-lite and zoiper softfones for created extensions. when i make a call from one softfone to another its ringing on both sides but no audio ater taking the call on both sides.
please help

Don’t install TrixBox it is totally unsupported. If you insist, try their support forums.