[SOLVED] Misc Destination Suddenly Ending Calls

Afternoon,

Here is the situation. My PBX has worked nearly flawlessly for the last few weeks. All of a sudden I have a problem when a call makes it to the Misc Destination. What happens is the pbx Dials the Answering service, when the answering service answers the call the call is suddenly ended! So I changed things to call my cell phone and when I answer my phone the same thing happens! So I changed things again and had it send calls to an internal VM and when the VM picks up the call is ended. Otherwise everything else is working correctly.

Things I’ve done.

Delete and make new ring group
Delete and make new Misc Destination
Uninstall Misc Destination
Rebooted
Full Power off
Had the trucks checked from the provider
Had the answering service line checked.

I am led to believe the problem is in the PBX due to it ending the call when it his a VM box, However as stated in a previous post I’m learning as I go with this…

Thanks for your help, Have a fun and safe holiday!
Matt

Can you provide a call trace?
What is your trunk type?
sip debugging on sip trunks and pri debugging on PRI could be super helpful

We use SIP trunks from nextiva. I will try to get a call trace ASAP

I think this is what you wanted?

[2014-07-03 15:43:04] VERBOSE[9929][C-0000026c] pbx.c: – Executing [[email protected]:20] ExecIf(“SIP/Nextiva-0000054b”, “0?Set(CONNECTEDLINE(name,i)=CID:7706864372)”) in new stack
[2014-07-03 15:43:04] VERBOSE[9929][C-0000026c] pbx.c: – Executing [[email protected]:21] GotoIf(“SIP/Nextiva-0000054b”, “0?customtrunk”) in new stack
[2014-07-03 15:43:04] VERBOSE[9929][C-0000026c] pbx.c: – Executing [[email protected]:22] Dial(“SIP/Nextiva-0000054b”, “SIP/Nextiva/8005798418,300,Tt”) in new stack
[2014-07-03 15:43:04] VERBOSE[9929][C-0000026c] netsock2.c: == Using SIP RTP TOS bits 184
[2014-07-03 15:43:04] VERBOSE[9929][C-0000026c] netsock2.c: == Using SIP RTP CoS mark 5
[2014-07-03 15:43:04] VERBOSE[9929][C-0000026c] app_dial.c: – Called SIP/Nextiva/8005798418
[2014-07-03 15:43:06] VERBOSE[9929][C-0000026c] app_dial.c: – SIP/Nextiva-00000551 is making progress passing it to SIP/Nextiva-0000054b
[2014-07-03 15:43:06] VERBOSE[9929][C-0000026c] app_dial.c: – SIP/Nextiva-00000551 answered SIP/Nextiva-0000054b
[2014-07-03 15:43:16] VERBOSE[2048][C-0000026d] netsock2.c: == Using SIP RTP TOS bits 184
[2014-07-03 15:43:16] VERBOSE[2048][C-0000026d] netsock2.c: == Using SIP RTP CoS mark 5
[2014-07-03 15:43:16] VERBOSE[2009] chan_sip.c: == Extension Changed 223[ext-local] new state InUse for Notify User 220

that doesn’t show a hangup

grep '0000026c\|0000026d' /var/log/asterisk/full

Ok,

Well why is the call being dropped? When the call is answered by the destination (answering service, My cell phone, or even the internal VM) the call is abruptly ended.

I have no idea why it started doing this, nothing has changed.

You didn’t answer James question about what type of trunking. You also did not provide the additional call trace.

You are with the system and if you don’t collect the data as requested none of the engineers can provide any help. We know you are frustrated but you have to follow a process.

If this is an urgent matter you may want to purchase support and have one of the Schmooze engineers look at your system.

I did answer his question to the trunks, they are Nextiva SIP trunks. I provided what I thought was the call trace, was i wrong?? Remember I am forcefully learning this system everyday… So if im not providing exactly what you want then its because I simply have no idea how to obtain it… I read posts after posts to correct things before I ask…

I provided the command to run

Thanks for your help. I have come to the conclusion that this is far over my “pay grade” and I’m walking away from this project and company.

You said it was “your” PBX.

Why don’t you utilize the Schmooze support?

I would like to know what was so hard? James gave you the command.

Mine as in the company I work for… The same company we discussed in a previous thread… The one that wont spend money on VPN hardware…

I tried to run the command and it froze the system each time…

I created a support ticket, and paid for it out of my own pocket as the company wouldn’t…

Long story short, I’m going back to windows admin stuff, pays more and less trouble.

Grep freezing a system is very odd. It’s not a “heavy” command. Grep just looks for the pattern in a file and outputs the lines that match.

As far as your employment, I hope it works out for you.

I don’t think windoze is posix compliant as yet, so grep is out for him :wink: they perhaps still have the old behavior for find in all files, you know , the one with the happy puppy , although I’m pretty sure that takes longer :slight_smile: , he could do a cifs mount (windows smb) of his /var/log structure onto a m$ machine and do it with that also. . .

That’s a bit cruel Dicko. If everyone was able to do this then the high demand for our services at $150-200 an hour would not exist. I don’t know any MS admin’s making that kind of cheese.

The dude tried, that’s more than many that come in.

Hey mmcghee (makes me want to go McFly…) I just thought of something. Make a short blank recording using systems recording module, like 1 second. Create an announcement with that blank recording. Now in the inbound route send the call the the blank announcement first then to the Misc. Destination. Does the problem go away?

If so your carrier is just barfing on what’s called “early media” I have seen this behavior before.

Take this all with a grain of salt. Been up all night rebuilding my mixing console for the home studio. Finally found the upgraded DSP board and external VGA for it. Figured while I had it open might as well clean all the faders, pots and lube the motors and the faders. Going to get some rest, let me know if that works.

I took most of the weekend off, I gave this a shot and now get a new problem. When the call transfers to the answering service I get silence. no ringing, no audio…

It’s a little hard to work with you as you are reluctant to paste the basically needed info.

Does your post indicate that the original problem is no longer pertinent, or that you have a new problem? What is your “Answering service” ?

In all cases just post a log of the call that failed and I am sure that some here at least will spend a few seconds analysing it for you, if you supply no information then . . . .

Ok first off give me a freaking break, as Stated more than once I’m learning this as I go. My linux experience is limited… What I do know about this phone system I learned on a sleep deprived Sunday night when the previous system died and the vendor was non responsive (still to this day haven’t heard from him)…

I didn’t bash your work platform, so don’t bash mine…

I paste what info I can, When the PBX freezes or simply ignores a command what do you suggest I do?

The Answering service is just that a live answering service. Call comes into the pbx, goes unanswered then is transferred to a answering service the one we use is Answer Connect.

I am not entirely sure if this is a new problem or not, I just know that there are less rings and more silence at this point.

There are logs written by default in /var/log/asterisk/full of everything useful about the any and all calls made, successfully and failing. (I believe windoze has a silmilar error logs). Simple extract that part of the log by any means that you are comfortable with and post it here.

You involuntarily used bash as a derogatory term, but in most versions of linux bash is the “shell” you need to work with. For windoze users you can get to there with “putty”, it is just like “cmd” in M$ .

Perhaps you should spend a few hours in the Wiki here and if necessary a quick trip to google for “bash tutorial” , hopefully you will soon be comfortable with your new chosen environment, many have taken that path to their delight.

(For copying files from a linux environment to another less able OS, winscp works with putty to provide an explorer like environment to do just that)