[solved] Kernel panic after today's system update

i am using freepbx 14 on a vm. everything is running fine.
after todays update via “yum update” and a reboot i get a kernel panic. when rebooting with a former kernel it works fine.

running kernel:
Linux freepbx.sangoma.local 3.10.0-514.16.1.el7.x86_64 #1 SMP Wed Apr 12 15:04:24 UTC 2017 x86_64 x86_64 x86_64 GNU/Linux

not working:

does anyone experienced something similar?

i can reproduce the issue. botting the newest kernel -> kernel panic
booting the former one -> freepbx starts fine.


I just got this myself when I needed to reboot a machine today.

My situation is slightly different. I am on FreePBX 13 on a VM. I didn’t perform a “yum update” directly but I suspect that the sysadmin update module runs it during it’s update process. I last updated so long ago I don’t remember but I think it was March. I am at 10.13.66-17 but there are updates available that would take me to 10.13.66-20 so that may fix my issue. I’ll try it after hours and see what happens and report back.

For comparison, this is the one that worked (the former of the two kernels I can choose from): 2.6.32-504.8.1.el6.x86_64 #1 SMP Wed Jan 28 21:11:36 UTC 2015 x86_64 x86_64 x86_64 GNU/Linux

This one did not work: vmlinuz-2.6.32-642.6.2.el6.x86_64

This is likely an OS upgrade glitch that could happen with certain hardware. I run VMware in case you are wondering.

Anyhow, i’ll see what happens tonight when I attempt to update to the latest version and i’ll let you know. I realize you are running FreePBX 14 which is EL7 and not EL6 so your mile may vary anyhow.

Feel free to ask me something I may have failed to mention. You didn’t by chance already figure out your issue did you?


no, not yet. just running the former kernel. will wait until a newer kernel is available and will boot again…

try yum update again

yes, latest kernel is working again (514.26.1)