[Solved] IVR sound doesnt play

Hello,

I am running asterisk 1.8 with freepbx 2.10. In FreePBX I have set up some user. Now I have set up a small test IVR, and uploaded a .wav file PCM encoded 8000HZ and 16 bits. But when I call my DID number I get the following error:

    -- Executing [[email protected]:21]BackGround("SIP/localtelecom-00000001", "test")in new stack

[2013-03-30 15:40:37] WARNING[3272]: file.c:663 ast_openstream_full: File test does not exist in any format
[2013-03-30 15:40:37] WARNING[3272]: file.c:958 ast_streamfile: unable to open test (format 0x4 (ulaw)): No such file or directory
[2013-03-30 15:40:37] WARNING[3272]: pbx.c:10083 pbx_builtin_background: ast_streamfile failed on SIP/localtelecom-00000001 for test
– Executing [[email protected]:3] WaitExten(“SIP/localtelecom-00000001”, “60”)in new stack

My context in extensions.conf is the following:

[from-localtelecom]
exten => 1000368,1,Goto(test,start,1)

[test]
exten => start,1,Answer()
same => n,Background(test)
same => n,WaitExten(60)
exten => 1,1,Dial(SIP/105,60,tr)
exten => 2,1,Dial(SIP/110,60,tr)

I need help with this error cause I’m stuck right now.

Can anyone help me, thanks in advance.

you can check if the file is compatible by issuing the following command
$file filename.wav
Also check ownership and permissions

Hello thanks for your reply, one question how can i check the ownership and permissions. And where do I need to enter the command $file filename.wav?

Thanks

Sound files for IVR are usually in /var/lib/asterisk/sounds/custom. Go to that directory.
ls -l will list the files in the directory, their ownership and permissions.
Should be owned by asterisk asterisk and 644 for permissions
[[email protected] custom]# ls -l
total 984
-rw-r–r-- 1 asterisk asterisk 7418 Mar 29 11:53 Directions.wav
[[email protected] custom]# file Open.wav
Open.wav: RIFF (little-endian) data, WAVE audio, ITU G.711 mu-law, mono 8000 Hz

Hello I get the following when I do ls -l:

-rw-r–r-- 1 asterisk asterisk 5327406 Mar 29 11:37 test.wav

When I do “file test.wav” it shows me this:

test.wav: RIFF (little-endian) data, WAVE audio, Microsoft PCM, 16 bit, stereo 8000 Hz

You need it to be mono. Asterisk won’t play stereo files

Ok, but is there a way to make it mono instead of stereo?

sox test.wav -c 1 tmp.wav;cp -f tmp.wav test.wav

Also, you can’t program IVR’s manually and use FreePBX, at least not the way you did it.

Why not just add the IVR from FreePBX web interface?

Thanks for the reply, I will try this tomorrow, But I have on question with it. Do I need to set up an dialplan to let it work, or do I just need the IVR in the FreePBX interface?

Just the IVR module.

Hello, I tried to call in just with the IVR from the FreePBX webinterface, but know my call is rejected, the error is the following:

[2013-03-31 00:27:52] Notice[3216]: chan_sip.c:23016 handle_request_invite: call from ‘1000368’ (208.64.255.24:5060) to extension ‘1000368’ rejected because extension not found in context ‘from-localtelecom’.

what does this mean?

Hello, I tried this but no luck it stays stereo

Did you just makeup the context from-localtelecom? That’s not a FreePBX context. Extensions should be in from-internal and trunks in from-pstn

Hello, I have fixed the problem. My dialplan looks like this right now:

[from-localtelecom]
exten => 1000368,1,Goto(test,start,1)

[test]
exten => start,1,Answer()
exten => start,2,Set(GLOBAL(sounds_path)=/var/lib/asterisk/sounds/custom)
exten => start,3,Background(${sounds_path}test1)
exten => 1,1,Dial(SIP/105,60,tr)
exten => 2,1,Dial(SIP/110,60,tr)
exten => t,1,Dial(SIP/999,60,tr)

Now it works perfectly, thanks for all the help.

Hi, I am trying out RasPBX (FreePBX on Raspberry Pi)... everything is working except I can't get any system recordings to play. I checked / changed ownership... permissions... directories... confirmed file formats. None of this is working for me.

Files were uploaded through the System Recording's GUI.

Error log looks like this:

<code>

[2013-11-06 20:04:14] VERBOSE[6841][C-00000002] pbx.c: -- Executing [[email protected]:9] Set("SIP/SIPAffinity-Proxy1-00000002", "IVR_MSG=custom/2014OGM1") in new stack
[2013-11-06 20:04:14] VERBOSE[6841][C-00000002] pbx.c: -- Executing [[email protected]:10] Set("SIP/SIPAffinity-Proxy1-00000002", "TIMEOUT(digit)=3") in new stack
[2013-11-06 20:04:14] VERBOSE[6841][C-00000002] func_timeout.c: -- Digit timeout set to 3.000
[2013-11-06 20:04:14] VERBOSE[6841][C-00000002] pbx.c: -- Executing [[email protected]:11] ExecIf("SIP/SIPAffinity-Proxy1-00000002", "1?Background(custom/2014OGM1)") in new stack
[2013-11-06 20:04:14] WARNING[6841][C-00000002] channel.c: Unable to find a codec translation path from (g729) to (slin)
[2013-11-06 20:04:14] WARNING[6841][C-00000002] file.c: Unable to open custom/2014OGM1 (format (g729)): No such file or directory
[2013-11-06 20:04:14] WARNING[6841][C-00000002] pbx.c: ast_streamfile failed on SIP/SIPAffinity-Proxy1-00000002 for custom/2014OGM1
[2013-11-06 20:04:14] VERBOSE[6841][C-00000002] pbx.c: -- Executing [[email protected]:12] WaitExten("SIP/SIPAffinity-Proxy1-00000002", "25,") in new stack

</code>

I have use FreePBX previously with a hosted setup (I administered it, but I did not do the installation or the problem solving) so I am relatively experience with the GUI setup (except this interface looks different from what I'm used ).   So, I'm not sure what to do next.

 

For the recod, I setup my Trunks with the "sample code" provided by my trunk provider (copied and pasted) and as I said, Calls in / out and between SIP extensions are working just fine.

 

Thank you for any help.

Jay