[Solved] IVR: Press 0 for operator (FPBX-2.10.0beta3)


This is a clean install of FPBX-2.10.0beta3, without restoring the old configuration.

Basic IVR works, but I cannot make it ring the Operator on pressing 0. Dial by extension works, dialing 9 brings DISA, etc., but pressing 0 leads to playback of invalid entry recording.

Operator Extension is set (in General Settings) to a ring group. Direct Dial set to Extensions or Directory, no difference.
In IVR settings I cannot manually configure “0” in IVR Entries - Ext, so I assume that 0 will be handled somehow automatically. Am I missing something?

I am experiencing the same issue as described above. New fresh install and new user data.

Can someone open a bug in FreePBX trac on this please.

Thanks a lot!

I upgraded from FPBX2.9 to 2.10Beta and had the same issue. As a workaround i added this in extensions_custom.conf

exten => 0,1,Goto(from-did-direct,5555,1)

It is working now…

If someone would open a bug I can get it assigned to a developer to get it fixed. Please post the bug number here once you get it opened.

Its tough looking in forums for bugs and we really appreciate it when someone can open a bug so it can be addressed.

Ok I went and opened a bug so this would not get missed.


OK new module for IVR has been published that fixes the 0 option bug.

I downloaded the update and is working.

Also the “i” and “t” options where deleted when i upgraded from 2.9 to 2.10; this update also correct this?


There is no i or t anymore. Invalid and Timeout is done in the main menu of the IVR not down below anymore.

See the dropdown about timeout and invalid destination. It should of migrated your i and t for you on upgrade.