[solved] Incomming calls no ringtone

Dear All,

Suddenly, incoming callers do not hear a ringtone on their end anymore. Nevertheless, calls can be completed without further issues - just the calling party has the impression that nothing happes during the silence until we do pick up. Generally, my setup is working for years without such issues.

The setting is: Dual SOHO with two freepbx installations in two different settings. Each on deidicated supermicro servers behind a pfSense firewall. No changes on other hardware or software in the relevant timeframe. No obvious causes of NAT issues that did not exist before. Each FreePBX 13, on based on the distro on Centos 6 and one installed on Centos 7. Same effect on both.

I did sense that one update (at least of module framework) did take unusually long and had to be initiated again. On the two installations mentioned plus my two warm spares on virtual machines.

If I recall correctly, there was one way to reinstall all modules command line while keeping the configuration. Unfortunately, I could not find how to do that. Can someone please remind me?

Next step, I would be glad to report if that helps and/or follow other advice.


Michael Schefczyk

1 Like

We had the same issue, but the issue was on our providers end. Confirm with them that all is good on their end.
You also might want to take a look at the logs.

Dear All,

Thank you very much, PitzKey!

Indeed, it does look the same at my end. If did trace packets on all levels of my network. The ringtone is sent out. I can hear it from the traces using wireshark. We mainly use Deutsche Telekom, the incumbent in Germany. On a secondary line with a cable provider, the ring tone does get through. The issue is even more strinking at Telekom: If the caller uses a landline Telekom identity as well, they will hear no ringtone. If the caller calls from a mobile phone or another network, the ringtone is delivered (even through Telekom’s network).

Does anyone have any further hints on how that may come about? I did try other nat settings but with no success, i.e., my ringtone packets to seem to get dropped in the critical case regardless of what I did so far.

Of course, I will ask our provider, but Deutsche Telekom is known to be catastrophic in this sense. Their position is that one should use their plastic equipment with proprietary software when connecting to their VOIP service.


Michael Schefczyk

Did you look at the asterisk logs? you can post them here (you can replace sensitive info with dummy numbers or IP addresses if necessary.)

Dear All,

Again thanks to PitzKey!

I did analyze the situation further, and I did solve it (hopefully). The issue was that - unlike during the previous years with Deutsche Telekom’s Voip service - one now needs to add the following the sip settings:


For those who are interested in understanding the issue and how to analyze it via packet capturing on the WAN side:

In my examples, the call is never completed, just ringing and than hanging up. In all scenarios, completing the call does work without any issues whatsoever. The problem is just, that the calling party may not hear a ringtone presumably after a recent modification on the side of the carrier.

From the called party side, the ringing of a call to FreePBX does look as follows, if progressinband=never is not set explicitly:

Then, the ring tone is delivered as an RTP stream just like the call itself. If the caller is using our incument carrier, that RTP stream does get dropped - unlike in the past years until a few days ago. The striking thing is that if the caller uses another carrier (or even Deutsche Telekom mobile) calling us through our Deutsche Telekom Voip line, the RTP stream will not be dropped, but delivered. I gather that modern sound logo ring tones also indicated that the ringtone is often delivered as an RTP stream. Then using a mobile phone instead of Telekom’s voip/landline, only difference is that the codec is then g711A instead of g722. However, this is not a codec issue: If I limit our Telekom trunk to that classic codec, the RTP stream does get dropped as well.

Ringing does work differently when not calling FreePBX but an AVM Fritzbox, the notorious (positive) market leading modem router in Germany if one disregards Deutsche Telekom’s speedport boxes:

In that case, there is no RTP stream required to deliver the ringtone to the calling party. That does work with callers from Deutsche Telekom’s network as well as from other networks.

That led me to search how to avoid the “early media” issue. So far - more insights may follow, of courese - the solutions seems to be “progressinband=never”. One reads that this should have been the default, but that does not seem to be true at least in asterisk 13.


Michael Schefczyk

Dear All,

Michael, thanks alot for your diagnostics and your work and for sharing here in the community!

I recognized that problem also when i was calling from another carrier (Telefonica) a customer that uses Deutsche Telekom.
I could reproduce that issue that day - today, as i wanted to find a solution (cause another customer told us, he had the same problem since the last freePBX-Upgrade i did on his machine) i could not reproduce it, unfortunatelly.

Anyway, maybe the default settings in Asterisk changed in the newer versions, and not the Deutsche Telekom changed her site.

I want to set that option, to be sure, that this problem will not come up again.

Michael, could you tell us where you did specify this option? in the trunk? in the general sip channel settings under “other sip settings”, or somewhere else?

I put it in the “other sip settings” - but as i cannot reproduce right now i am unsure if that is the right place, or if it has to be set in the trunk only.

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.