[solved] How-To FIX: Time Groups / Time Conditions (7 hours ahead)

Hi SangomaOS Team:

We are using a very recent .ISO of SangomaOS
We have the System Admin Pro module

The date/time is 100% correct in all accepts except one.

timedatectl = correct
date = correct
Using *60 feature code = correct

The timezone has been set correctly (System Admin Pro)

/etc/php.ini has the correct setting: “America/Los_Angeles”

/etc/localtime has been looked at

The (2) modules inside of the UI still have incorrect “server time”
Time Conditions
Time Groups

They are both (7 hours) ahead

This is the only place on the PBX where the time is not correct.

Thank you for any tips.

1 Like

I just installed a new ISO today to convert an on prem system to cloud. Same problem. In Los Angeles. Time is correct everywhere except in System Admin/Time Zone.

Curious to see what the fix might be here…

There’s bug opened about this.


Fix coming soon.

I think the fix is already in if you upgrade the framework module to the latest version, which I think is 16.0.39.

Today, we upgraded the modules …
We got FreePBX framework to 16.0.39

After the update:
The “server time” shown in both of the two modules is still 7-hours ahead.

Those two modules are using UTC -0
We are in UTC -7

The rest of the time is correct throughout the system (even at the CLI level).

Thanks for any thoughts or tips.

When you say they are using you mean that is what they are set to? Because Time Conditions can their own time zone applied per condition. What are the time zones set to in the Time Conditions?

Hi Tom:

Have not spoken to you in a long time.

The time inside of the timezone section of System Admin Pro is:


The “Server time” (in the green box next to the Time Zone):
This is off by -7 hours

UTC -0 (is what it is now)
Should be UTC -7

The rest of the PBX (even the CLI) has the correct UTC -7 time


Even if I pick a different timezone inside of Time Conditions, the label outside of both Time Groups and Time Conditions keeps its “incorrect” time of UTC - 0 (we are UTC -7) America/Los_Angeles

There are no timezone choices inside of Time Groups only Time Conditions has this option.

Thanks for the tips.


FreePBX 16 (all modules up to date / current)
FreePBX Framework = 16.0.39

Even the CDR module is showing the time as being “7-hours” ahead.
The time in the reports is off.

If we run timedatectl = correct time
If we run date = correct time

The time in system admin pro (timezone) (UI) is off (ahead) by 7 hours

I have found a 2nd box with this same condition.
We have other FPBX 16 up to date boxes where the time is correct in the UI (and) the modules

Thanks for any tips or suggestions.

Is the time zone in advanced settings set correctly?

I am trying to reproduce this.


Hi SangomaOS Team:

Even with the update to FPBX Framework 16.0.40 …

Time Conditions
Time Groups
System Admin Pro (timezone)

These UI features show the time “ahead” by 7 hours


using feature code *60

These have the time/date correct.

This same condition is happening on more than one SangomaOS 16 FPBX unit we have.

Thanks for any tips/suggestions.

This is not the Sangoma OS team. It is a peer support forum, open to the general public, which happens to include some Sangoma employees.

If you want to reach the Sangoma OS team (or whatever carries out that function) you need to raise a commercial support request, or create an issue, at issues.freepbx.org. For the latter, you will need a detailed procedure to reproduce the problem.

1 Like

Nice point, but I know this better than most. I think you have it somewhat backwards.

Yes, this is a public forum, but it is owned by the SangomaOS processes.

I know the SangomaOS Team is here watching the forum and posts.
It is what they do … This is their house!

Most of the good replies you’ll get are from their staff.

Can you please elaborate a bit more? Are they all on the same network? What about the advanced settings I agreed above?
Were they all clean 16 installs?

Since we have many SangomaOS (FreePBX 16) installs and this concern is only happening on (2) instances …

I confirmed that for the (2) instances where the time is “ahead by 7 hours” … these (2) units have nearly the same hardware (meaning) the cabinet is the same (they are both made by the same MFG).

I wonder now if: maybe this is tied to the HARDWARE clock process since these two units have the nearly the same exact physical hardware.

Perhaps… But would you mind providing more details?

Thank you.
This was the fix.

Inside: Advanced Settings

The default timezone was set to: UTC

Changed this to: America/Los_Angeles

Saved (no reboot needed).

The time is now listing as PDT (and no longer as) UTC

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.