SOLVED - GraphQL API - possible to disable / suppress the welcome email?

(Sholinaty) #1

I found the “AddExtension” Graphql API. it seems nice.

i was surprised however to see that my test user received an email containing my device password and extension.

is there a way to suppress this welcome email? we handle hardware setup, have a centrally-managed softphone, and don’t use the user portal, so the end user does not need (and should not have) the password that is being sent.

we DO need the email address in there for voicemail-to-email however, so simply not including the email is not an option.

(Andrew) #2

Have you tried setting umEnable to False? It’s True by default.

(Sholinaty) #3

to be entirely honest, i had simply removed the “optional” umEnable line. will try it again with that explicitly disabled.

you’re right though, from here, it seems it does default to on.
note: the above doc seems outdated, as the sample code mentioned clientMutationId: but that is not in the table above.

give me a moment to investigate umEnable False.

(Sholinaty) #4

sending umEnable: False successfully stops this behaviour.

for completeness, here is a very basic GQL example im using in postman.
POST to http://{{sever}}/admin/api/api/gql
graphQL query:

          input: {
              extensionId: 1234
              name: "graphql test"
              tech: "pjsip"
              outboundCid: ""
              email: "user@domain.tld"
              umEnable: false
              vmPassword: "4321"
              vmEnable: true
      ) {

which gives the response:

    "data": {
        "addExtension": {
            "status": true,
            "message": "Extension has been created Successfully"

(Itzik) #5

If you set this to no, then you don’t need to pass the umEnable: falst

(Sholinaty) #6

Thank you for that as well, PitzKey. very handy.

(system) closed #7

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.