[Solved] fwconsole file is not accessible

I am trying to do a new clean install of the latest FreePBX distro. I downloaded the ISO from:

I took the easy round and did an automatic install, and have also tried the advanced install. They both end with the same result. Upon the initial reboot after the installation is complete, I get this message when logging in as root at the console:


Unable to generate MOTD.
The /usr/sbin/fwconsole file is not accessible

You are likely to experience significant system issues.

I’ve seen reports of this on some very old releases and was surprised to find it on the most recent release. In any case, I’ve not found a way around it, nor any explanation as to exactly what happened during the install to cause it.

If anyone can help me get a clean, working install of FreePBX, it would be much appreciated.

Thank you

What are you installing to? Maybe there is an issue with the hardware or the VM you are trying to get this to run on?

Thanks for your response. I was installing into a Proxmox VM with 4 cores and 2GB of memory.

I think I found the problem… 2GB wasn’t enough. Bumping the memory to 4GB changed the outcome and now I no longer get the fwconsole error.

It would have been nice if the installer would have checked the memory and warned that there wasn’t enough.

I am not sure why your system was blowing up at 2Gig but we have FreePBX systems with 1Gig of RAM and they are working just fine.

I agree it’s odd, especially since after the installation it only need about 1GB to operate. Something in the install is sucking up memory.

I’ve seen something similar with Solaris 11.4 updates… they use a python script to manage dependencies, etc. and it is notorious as a memory sink. It’s so bad that Oracle states you need 8GB to install a Solaris update, but again, only need 1GB or so to operate.

I’ve not seen this in other linux installations, so my guess is it’s probably related to some setup processes for Asterisk and FreePBX that’s happening during the install.

I too have had this issue before. I think I needed 2 GB to install but it will then run even under 1GB. The install process has obviously got more bloated.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.