[solved] freepbx with lancom router

hi there,

i want to use freepbx in combination with my lancom 1823 voip router. the router is connected via isdn to the cable network. i want to configure freepbx so that it uses the two isdn channels for outgoing/incoming calls. furthermore, i want to use additional voip trunks configured at feepbx for outgoing calls.

lancom offers a tutorial (unfortuneately in german, but the asterisk syntax shall be understandable) http://www2.lancom.de/kb.nsf/b8f10fe5665f950dc125726c00589d94/e1759294d6f0c6e0c12573e60050acb4?OpenDocument

now my questions:

  • freepbx uses mysql instead of the config files. where can i setup all the settings, e.g. extensions.conf?

  • i have created a user to connect freepbx with lancom router. the outbound route of freepbx doesn’t work, i always get a line is busy signal. a trace of the call is attached.

----- snip
SIP-Packet] 2009/11/27 01:18:33,010 [PACKET] :
Receiving datagram with length 824 from 192.168.1.66:5060 to 192.168.1.200:5060
INVITE sip:[email protected];user=phone SIP/2.0\r\n
Via: SIP/2.0/UDP 192.168.1.66:5060;branch=z9hG4bK435e1a38;rport\r\n
From: “44” sip:[email protected];tag=as0cceadf6\r\n
To: sip:[email protected];user=phone\r\n
Contact: sip:[email protected]\r\n
Call-ID: [email protected]\r\n
CSeq: 102 INVITE\r\n
User-Agent: Asterisk PBX\r\n
Max-Forwards: 70\r\n
Date: Fri, 27 Nov 2009 07:13:54 GMT\r\n
Allow: INVITE, ACK, CANCEL, OPTIONS, BYE, REFER, SUBSCRIBE, NOTIFY\r\n
Supported: replaces\r\n
Content-Type: application/sdp\r\n
Content-Length: 285\r\n
\r\n
v=0\r\n
o=root 3149 3149 IN IP4 192.168.1.66\r\n
s=session\r\n
c=IN IP4 192.168.1.66\r\n
t=0 0\r\n
m=audio 14478 RTP/AVP 0 8 3 101\r\n
a=rtpmap:0 PCMU/8000\r\n
a=rtpmap:8 PCMA/8000\r\n
a=rtpmap:3 GSM/8000\r\n
a=rtpmap:101 telephone-event/8000\r\n
a=fmtp:101 0-16\r\n
a=silenceSupp:off - - - -\r\n
a=ptime:20\r\n
a=sendrecv\r\n

[SIP-Packet] 2009/11/27 01:18:33,020 [PACKET] :
Sending datagram with length 434 from 192.168.1.200:5060 to 192.168.1.66:5060
SIP/2.0 404 Not Found\r\n
Via: SIP/2.0/UDP 192.168.1.66:5060;branch=z9hG4bK435e1a38;rport\r\n
From: "44"sip:[email protected];tag=as0cceadf6\r\n
To: sip:[email protected];user=phone\r\n
Call-ID: [email protected]\r\n
CSeq: 102 INVITE\r\n
Max-Forwards: 70\r\n
User-Agent: LANCOM 1823 VoIP (Annex B) / 7.70.0100 / 18.08.2009\r\n
Server: lancom\r\n
Allow: REGISTER, INVITE, ACK, CANCEL, BYE, REFER, NOTIFY, OPTIONS\r\n
Content-Length: 0\r\n
\r\n

[SIP-Packet] 2009/11/27 01:18:33,020 [PACKET] :
Receiving datagram with length 374 from 192.168.1.66:5060 to 192.168.1.200:5060
ACK sip:[email protected];user=phone SIP/2.0\r\n
Via: SIP/2.0/UDP 192.168.1.66:5060;branch=z9hG4bK435e1a38;rport\r\n
From: “44” sip:[email protected];tag=as0cceadf6\r\n
To: sip:[email protected];user=phone\r\n
Contact: sip:[email protected]\r\n
Call-ID: [email protected]\r\n
CSeq: 102 ACK\r\n
User-Agent: Asterisk PBX\r\n
Max-Forwards: 70\r\n
Content-Length: 0\r\n
\r\n[TraceStopped] 2009/11/27 09:10:53,000
-----snip

if i put the user 44 credentials in a sip phone, it works -> config on lancom side seems to work.

Any suggestions why i cannot make an outgoing call from a phone logged in at the freepbx using the lancom outgoing route?

christian

first of all thangs for the answers
i have managed now the setup a step further. I can make internal calls and external calls via the voip trunk. but i am not able to answer incoming calls (busy sign for the caller) or outgoing calls via the lancom router (isdn). i get always a line busy signal.

accoring to lancom support, the router cannot handle trunks. thus, how can i setup the following?
exten => _X.,n,Dial(SIP/${EXTEN}@192.168.10.1|40|r)
$exten should be the sip user connecting the lancom and the freepbx.

thanks for the help!

I have not set up any VOIP’s yet.

I recommend this reading.

PBX in a Flash® without Tears: http://dumbme.mbit.com.au/PiaF/PiaF_without_tears.pdf
Chapter 7

And this Forum is another good one:
PBX in a Flash Forum: http://pbxinaflash.com/forum

Hope that helps

I can only answer this question:

  • freepbx uses mysql instead of the config files. where can i setup all the settings, e.g. extensions.conf?

Once you have set the IP address on your FreePBX server, you put that in your browser (from a PC on the same network of course).

Then click on Admin in the lower left and then FreePBX Administration.

And when that comes up you will see Extensions, etc. under the Setup tab.

Am I off base?

hello tadpole,

thanks for the reply. i have found the setup, of course, but i do not find in the general settings some of the features listed in the sip.conf, e.g.
[general]
port = 5060
bindaddr = 0.0.0.0
context = sonstige
allowguest=yes
srvlookup=yes
canreinvite=no
language=en

and where can i realize this what should be in the extensions.conf?
[my-phones]
exten => 300,1,Dial(SIP/300)

exten => _20X,1,Dial(SIP/${EXTEN})

exten => _X.,1,Verbose(2,Dialing to User ${EXTEN} on Lancom)
exten => _X.,n,Dial(SIP/${EXTEN}@192.168.10.1|40|r)
exten => _X.,n,Verbose(2,${DIALSTATUS})
exten => _X.,n,Hangup

port = 5060 is set in the Extensions. I believe that it does not ask initially, being that 5060 is the default, but when you edit a SIP Extension it shows it.

context and canreinvite are Extension settings also.

Language is setup in the Language tab.

Most of the rest is under the Tools tab and then Asterisk SIP Settings menu.

As for what should be in Extensions, etc. … I learned a lot from this doc:
PBX in a Flash® without Tears: http://dumbme.mbit.com.au/PiaF/PiaF_without_tears.pdf

I am writing my own guide to a specific system, too… It might help:
http://www.scribd.com/share/upload/15898071/sjid7tds835ug58ea5v

the name’s Cliffster (and I am but a tadpole, like yourself) :slight_smile:

The info you have is for Asterisk without FreePBX. FreePBX does most of the work for you.

The extensions are built by FreePBX for the dial plan. You should be able to make the device work simply be setting up a trunk to it.

The context they used is only for an example. FreePBX has it’s own context’s IE: from-internal, from-pstn etc.

ok, i have finally managed it to get everything working. the required options are sometimes hard to find, but now it works.

thanks for all answers!

excellent thanks for the update