[SOLVED] FreePBX 16: Apply Config generates error


(Siljaer) #1

Hello,

my problem is very similar to the one described in:

https://issues.freepbx.org/browse/FREEPBX-22803?jql=text%20~%20"apply%20config"%20ORDER%20BY%20created%20DESC

I can’t apply config from web GUI, I have to ssh and use

fwconsole reload --verbose

the command does not return any information besides “reload complete”.

I installed the server on a nano pi neo 3 running Armbian 21.08.2 Focal.

I compiled MariaDB connector from source and I installed pm2 as required, so everything is in order.

FreePBX Framework version is 16.0.10.33

FreePBX Core version is 16.0.56.14

Asterisk version is 18.6.0.

I installed all the software a few days ago. If I remember well, at the beginning I could apply config without generating an error. There was another bug, though, that prevented FreePBX from updating. So I updated from the console, but now I have this problem.

Apart from that, the server is working on my simple setup; I use it to manage my phone line migrated to FTTH.

What should I do?


(Lorne Gaetz) #2

Try running the reload as the ast user

sudo -u asterisk fwconsole r --verbose

(Siljaer) #3

Output is:

In Reload.class.php line 935:
                                                                                              
  [Whoops\Exception\ErrorException (2)]                                                       
  file_put_contents(/var/run/asterisk/reload.lock): failed to open stream: Permission denied  
                                                                                              

Exception trace:
  at /var/www/html/admin/libraries/Console/Reload.class.php:935
 Whoops\Run->handleError() at n/a:n/a
 file_put_contents() at /var/www/html/admin/libraries/Console/Reload.class.php:935
 FreePBX\Console\Command\Reload->setLock() at /var/www/html/admin/libraries/Console/Reload.class.php:74
 FreePBX\Console\Command\Reload->execute() at /var/www/html/admin/libraries/Composer/vendor/symfony/console/Command/Command.php:255
 Symfony\Component\Console\Command\Command->run() at /var/www/html/admin/libraries/Composer/vendor/symfony/console/Application.php:992
 Symfony\Component\Console\Application->doRunCommand() at /var/www/html/admin/libraries/Composer/vendor/symfony/console/Application.php:255
 Symfony\Component\Console\Application->doRun() at /var/www/html/admin/libraries/Composer/vendor/symfony/console/Application.php:148
 Symfony\Component\Console\Application->run() at /var/lib/asterisk/bin/fwconsole:163

reload [--json] [--dry-run] [--skip-registry-checks] [--dont-reload-asterisk]

(Lorne Gaetz) #4

Most permissions issues are resolved by running this as root

fwconsole chown

(Siljaer) #5

It worked! Thank you.


(system) closed #6

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.