FreePBX | Register | Issues | Wiki | Portal | Support

[SOLVED] FreePBX 14 and Asterisk 13 Error while ./install -n

asterisk
freepbx
Tags: #<Tag:0x00007f74989d8f28> #<Tag:0x00007f74989d8dc0>

(Enmanuel Nagy) #1

Hello guys

I’m installing FreePBX 14 and Certified Asterisk 13 over CentOS 7

Everything goes well until I’m installing FreePBX (I’m following the wiki instructions), so when I run the command /install -n I get this error:

Assuming you are Database Root
Checking if SELinux is enabled…Its not (good)!
No /etc/asterisk/asterisk.conf file detected. Installing…Writing /etc/asterisk/asterisk.conf…Done
Checking if Asterisk is running and we can talk to it as the ‘asterisk’ user…Error!
Could not determine Asterisk version (got: Asterisk certified/13.21-cert3 built by root @ fpbx-00 on a x86_64 running Linux on 2019-05-05 05:09:31 UTC). Please report this.

The installcommand.class.php script seems to be able to run a core show version, but for some reason it doesn’t recognize it

I also tried to install Asterisk 16 but I get the same error.

I made sure I ran these commands:

chown asterisk. /var/run/asterisk
chown -R asterisk. /etc/asterisk
chown -R asterisk. /var/ {lib,log,spool} /asterisk
chown -R asterisk. /usr/lib64/asterisk
chown -R asterisk. /var/www/

So it doesn’t seem to be a permission issue.

Anyone can point me in the right direction to work around this?


#2

Just before the ./install -n, is Asterisk actually running as the asterisk user (what does
ps aux | grep asterisk
show)?

If not, does starting it with
./start_asterisk
work, or does it die again?

I had trouble related to the /etc/asterisk.conf generated by the install script and created one manually.
See my script at http://x-sc.com/fpbx14g.sh . This is intended for GCP and is likely not appropriate for your system so don’t try to run it directly. However, the last section labeled “install and start FreePBX” may give you some ideas.


(Enmanuel Nagy) #3

Hello Stewart1,

Yes, Asterisk is up and running before I run the./install script.

And I assume the ./start_asterisk start works fine since it prints:
STARTING ASTERISK
Asterisk Started

The output from ps is this:
[root@fpbx-00 ~]# ps aux | grep asterisk
asterisk 8244 0.0 0.9 582140 10072 ? S 00:29 0:00 /usr/sbin/httpd -DFOREGROUND
asterisk 8245 0.0 0.9 582140 10072 ? S 00:29 0:00 /usr/sbin/httpd -DFOREGROUND
asterisk 8246 0.0 1.0 582140 10304 ? S 00:29 0:00 /usr/sbin/httpd -DFOREGROUND
asterisk 8247 0.0 0.9 582140 10072 ? S 00:29 0:00 /usr/sbin/httpd -DFOREGROUND
root 8267 0.0 0.0 113180 804 pts/0 S 00:29 0:00 /bin/sh /usr/sbin/safe_asterisk -U asterisk -G asterisk
asterisk 8270 0.0 2.9 643612 30144 pts/0 Sl 00:29 0:01 /usr/sbin/asterisk -f -U asterisk -G asterisk -vvvg -c
asterisk 8338 0.0 0.9 582140 10092 ? S 00:31 0:00 /usr/sbin/httpd -DFOREGROUND
asterisk 8340 0.0 0.9 582008 9580 ? S 00:31 0:00 /usr/sbin/httpd -DFOREGROUND
asterisk 8341 0.0 0.9 582008 9352 ? S 00:31 0:00 /usr/sbin/httpd -DFOREGROUND
asterisk 8342 0.0 0.9 582008 9352 ? S 00:31 0:00 /usr/sbin/httpd -DFOREGROUND
asterisk 8343 0.0 0.9 582008 9352 ? S 00:31 0:00 /usr/sbin/httpd -DFOREGROUND
asterisk 8344 0.0 0.9 582008 9352 ? S 00:31 0:00 /usr/sbin/httpd -DFOREGROUND
root 9040 0.0 0.0 112728 980 pts/1 S+ 01:00 0:00 grep --color=auto asterisk


#4

I’m puzzled. Possibly, the ‘certified’ stuff is confusing the version parsing and erring out for no good reason. Or, maybe Asterisk starts ok but crashes a few seconds later and is repeatedly restarted by safe_asterisk.

After starting Asterisk, can you connect to the console (type
asterisk -r
at a root shell prompt), wait 30 seconds, then type
core show version
? If the same instance of Asterisk is still alive at that point, what does that show? My test system shows:
Asterisk 16.1.1 built by root @ myhostname on a x86_64 running Linux on 2019-01-29 17:02:33 UTC


#5

Possibly you chose the “wrong” directory when you got your sourcce? . . .

http://downloads.asterisk.org/pub/telephony/

And the version check in FreePBX didn’t pass muster.


(Enmanuel Nagy) #6

SOLUTION/WORK AROUND:

Thanks for the replies, Stewart1 and dicko

I also suspected that the “Certified” word in the name was confusing the freepbx install script, so I downloaded the simple LTS version of Asterisk 13 (version 13.26.0 is the latest) and everything went OK. So I now have a FreePBX 14 working with Asterisk 13.26.0 LTS

So I’m not sure where to report that some sort of check should be made to the install script in order to accept a certified version.

For future readers, I will mark this as solved but keep in mind that as of may 2019, the freepbx 14 install script will produce an error if you are working with a certified version of Asterisk

For now, I’m setting up a VM with Asterisk 16 and will also try it out, since Asterisk 16 is the latest LTS version.

Cheers


#7

You probably don’t fit the designed user of “certified asterisk”

I suggest you stay inside the FreePBX ecosystem


(Enmanuel Nagy) #8

Special thank you for this,

This actually helped me with another freepbx 14 installation with asterisk 16.03, I had to manually generate the asterisk.conf


(system) closed #9

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.