SOLVED - Endpoint Manager forcing HTTP authentication


I just recently noticed that after I saved and rebuilt some config files for my Yealink phones that all the cfg files have the auto_provision.server authentication parameters set, even though I have it disabled through the Sysadmin Provisioning Management.

I can force a custom URL to fix it but it was working fine awhile ago.

I was using EPM 13.0.99 at first, then upgraded to Edge and got with the same problem.

This is by design, and the provisioning URLs should work with credentials even if not required by your server.

We do this by design. The reason is lets say today you decide not to have auth enabled. But tomorow you want to. if you enable auth in the PBX the phones wont have the auth username and password and they wont be able to get it as you have now locked porvisioning by auth.

If we provide auth and the server is not setup for it today it does not hurt anything as apache just ignores it. That way tomorrow if you enable it nothing breaks.

Thanks guys!

I was probably looking into it too much as I’ve recently migrated from a cloud provider to an in house server. In my eyes it seems as the phones’ notification light will flash for a long time before stopping on boot, so I was looking at anything that might have been different.

Again, thanks for your time.