[SOLVED] DAHDI install issues


I built my system (FreePBX from scratch on Centos 6.2 x86_64 and installed DAHDI from source (dahdi-linux-complete-2.6.0+2.6.0), at the time. I knew it had to be installed for timing purposes, but not having the need to use it explicitly I never gave it a second thought. However recently I thought I might get conferences up and running which need DAHDI.

when I issue CLI> dahdi show status, I get:
“No DAHDI found. Unable to open /dev/dahdi/ctl: No such file or directory
Command ‘dahdi show status’ failed.”

At the command prompt if I type service dahdi status I get nothing returned back. However if I try to start or restart the service using service dahdi start I get:

"Loading DAHDI hardware modules:
FATAL: Module dahdi not found.

Error: missing /dev/dahdi!"

I then checked the DAHDI config files in etc/dahdi and commented out the devices, not being used. Still no dice.

So then (thinking it was a good idea at the time) I thought I’d try reinstalling DAHDI using yum, yum install asterisk-dahdi

This went ahead and installed asterisk-dahdi package. It also installed the dependencies (as it should) including:

asterisk x86_64 epel 3.0 M
dahdi-tools x86_64 epel 134 k
dahdi-tools-libs x86_64 epel 25 k
libpri x86_64 1.4.12-1.el6 epel 179 k
libresample x86_64 0.1.3-12.el6 epel 24 k
libsrtp x86_64 1.4.4-4.20101004cvs.el6 epel 273 k
libss7 x86_64 1.0.2-1.el6 epel 53 k

So foolishly I had overwritten my otherwise working (and patched) Asterisk install. Thankfully however yum had not overwritten the existing config file (merely appended .rpmnew to those it had installed), so getting my system back simply involved an Asterisk reinstall from my source files.

I suppose the good thing is that all the requisite DAHDI pre-requsities, like libss7 are now installed without doubt, however DAHDI is still not working for me.

Any ideas as to what I should try next?


Apparently “DAHDI is a kernel module, which means you need a version that exactly matches your kernel version”. Following advice located on the Digium forums I found that I had a mismatch between my current kernel and the version for which DAHDI had been installed…

run uname -a to get the kernel version

Confirm the DAHDI modules are installed for your kernel version, go to /lib/modules/[kernel version]/dahdi/

They should all be there. In my case they weren’t there, they were in the /lib/modules directory for an older kernel (that I think I had installed when I first compiled/installed DAHDI initially).

So simple fix was to recompile and re-install DAHDI (for me from source):

cd /usr/src/
wget http://downloads.asterisk.org/pub/telephony/dahdi-linux-complete/releases/dahdi-linux-complete-2.6.0+2.6.0.tar.gz
tar zxvf dahdi-linux-complete-2.6.0+2.6.0.tar.gz
cd dahdi-linux-complete-2.6.0+2.6.0
make all
make install
make config
/etc/init.d/dahdi restart
chkconfig dahdi on

then a reboot to make sure all was well and starting correctly.

Into Astersik and issue CLI> dahdi show status

and get:
“Description Alarms IRQ bpviol CRC Fra Codi Options LBO”


In case anyone finds this remotely useful, I’ve just updated my system to CentOS 6.4 and found that the previous stable version of DAHDI v2.6.1 was not reloading properly following a reboot.

I noticed that Digium have just published a new version 2.6.2, a few days ago, so re-complied and installed that version and all seems to reload properly/automatically after a system reboot.

I’m not exactly sure what has changed between, the two most recent DAHDI version as Digium have not yet published a Change Log for v2.6.2, but I’m sure that will be updated in the next few days.

You really saved my day…
Thanks a lot, after done the Elastix Hardware Detector worked well!!!
Peace from Brazil

Hi simcity,

In case you are still around the forum, thanks for the post help you too :slight_smile:

Cheers berrick.