SOLVED - COS and outbound routes not working as desired [PROBLEM RECONFIRMED] When the pre-fix code used is +91 or +1 , basically +xx The routes stop honoring the COS

I have multiple trunks in the following outbound route

  • Trunk 1 - Outbound1 - dial pattern 81-NXX-NXX-XXXX - COSGrp1
  • Trunk 2 - Outbound2 - dial pattern 81-NXX-NXX-XXXX - COSGrp2
  • Trunk 3 - Outbound3 - dial pattern 81-NXX-NXX-XXXX - COSGrp3
  • Trunk 4 - Outbound4 - dial pattern 001-NXX-NXX-XXXX - COSGrp4

I have multiple extensions

  • Ext 1 - 10 - COSGrp1, COSGrp4
  • Ext 11-20 - COSGrp2, COSGrp4
  • Ext 21-30 - COSGrp3, COSGrp4

What is required:
When extension group 1-10 dial 81, they shud be able to access only Outboun1 line, using the dial pattern 81
However, when group 11-20 dial 81 - they should be able to dial out only through Outbound 2 line.
Similarity group 21-30 dial 81, they should be able to dial through outbound3 line.


Irrespective of whether Trunk1 is allowed in COSGrp1 or not, if this is put on top (in oubound list) - ANY MEMBER OF ANY COS group, can dial out using this number - as the dial patter matches.

My versions
PBX Firmware: 10.13.66-9
PBX Service Pack:
COS - 13.0.9

I anybody also having similar problems. ?

Am I missing any other piece of configuration. ?


Logically it seems that “should” work but the similar patterns may be at issue. Try adding an extension range in the CallerID section of your dial patterns like ( I am going to substitute your ext ranges to something that can work )

  • Ext 1 - 10 - COSGrp1, COSGrp4 --> 100-109 or 10X
  • Ext 11-20 - COSGrp2, COSGrp4 --> 110-119 or 11X
  • Ext 21-30 - COSGrp3, COSGrp4 --> 120-129 or 12X

  • Trunk 1 - Outbound1 - dial pattern 81NXXNXXXXXX - 10X - COSGrp1
  • Trunk 2 - Outbound2 - dial pattern 81NXXNXXXXXX - 11X - COSGrp2
  • Trunk 3 - Outbound3 - dial pattern 81NXXNXXXXXX - 12X - COSGrp3
  • Trunk 4 - Outbound4 - dial pattern 001NXXNXXXXXX - COSGrp4 <-- not needed here as it should be listed after the other routes.

Also, presumably you didn’t really have hyphens in your dial patterns. I removed them for acuracy.


Thanks for your response.

  1. Extension ranges will not help - as our extensions in real life are not in a range - and that was the whole purpose of buying class of service

  2. The dialpattern Trunk 4 IS required, since I want it addressed only when users of ANY COS GROUP to use it - if I do NOT make ALL users a part of SOME COS group, they will have access to all COS groups, hence I NEED a COS group.

The expected logic is each group has its ‘personal’ outbound route, that they use “81” to dial out a NXX-NXX-XXXX route.
And all users use “001” to dial out a NXX-NXX-XXXX route

I see… you represented the extension in a range so I went with that…

IMHO prepend’s should be different or perhaps not used at all. COS should be able to specify what routes an extension uses.

Wish life was that simple.

This deployment is for an organisation which has end points in 3 countries (USA, India and UK) and trunk lines out of these three.

The COS is important, as we do NOT want wrong routes to be make wrong calls, you do not have India numbers to be dialed via the USA route and so on…


The problem statement remains -

COS is not working as it is supposed to be …

Trunks are not part of COS. Only Routes are part of COS so once you setup a COS to have access to a route and it matches that route what you dial it will us that route.

Thanks Tonyclewis,

However, that is EXACTLY my problem statement.

Even those routes, that are NOT supposed to have been accessed by my COS - are getting accessed, since they are up on the Routes list.


You must have something wiht your COS setup wrong as I just tested and works fine here.

Awesome… so, do you have something like this setup

Extn Grp 1 - dials 81 - they go out from Route 1
Extn Grp 2 - dials 81 - they go out from Roue 2
Extn Grp1, 2 dials 0 - they go out from Route 3

Is this setup (or similar to it) working ?

Yes its how we run our corp PBX very similar.

All the Toronto Staff go out route that uses local Canada Trunks and Canada Caller ID

All US Staff go our route to SIP trunks that us a US Number

No - I don’t like your reply… (just kidding) It means, I got to clean up and redo all the routes…

Thanks for the confirmation, I will clean it up and re-do the outbound routes and COS and then revert.

A small question.

Within the same COS. How does the route dialing see priorities

This is in COS

This is in Outbound routes

Assuming, the dial-pattern matches for both the routes… which one will be picked first Route 1 or Route 2


Ok guys, based on the above recommendations, I had cleaned out all my

  • Out bound routes
  • All COS


  • Created outbound routes
  • Members of COS

Outbound route looks like this.

COS List is like this

COS Appy has these members

And COS Appy has these routes

707 does NOT belong to Appy COS


Inspite of the above settings -

When I use 707 to dial out, using the dial out code +1-XXX XXX XXXX

It dials out using Route 35- Appy route - TO WHICH IT IS NOT SUPPOSED TO HAVE ACCESS

It is beginning to look like a bug now…

Any thoughts/suggestions ?


Here is the final result of redoing everything in baby steps, and finally this is the problem statement.

I have confirmed it on two different installations.

When the pre-fix code used is +91 or +1 , basically +xx The routes stop honoring the COS

For all other pre-fix code, the COS service is working very effectively.

@tonyclewis - Any thoughts. The issue is NOT with COS (as I disabled the same and left only the extension routing)

However, even then the problem remains.

This is correct. If a extension is not part of a COS then it has NO restrictions. Can dial anything.

That is NOT the case here,

Extensions that are a part of ONE COS - are able to access routes, that do NOT belong in this COS.

However, this is the case ONLY when the prefix code used to access this route is “+”, for all other prefixes, the routes, extension routing (when COS is disabled) and COS works just fine.


SOLVED - there WAS a bug in the Extension routing, this has now been fixed on

Changelog - Extension routing Allow processing of numbers prefixed with +
13.0.8: Hide config options when adding extension