SOLVED: config for linksys pap2 register with remote freepbx 12

I’m running centos 6.6 on a remote vps with freepbx 12 on it, after searching google I’ve found nothing but dead links and I’m having difficulty getting a linksys pap2 to register with freepbx. I know freepbx is working ok because I’ve managed to register two cisco phones to it. I’ve done a wireshark run on the vps and I can see the linksys is making contact but freepbx just gives ‘(fetch bindings)’ in the console. I’ve been thru the extensions settings and can’t see anything amiss. Does anyone know the correct way to configure the linksys pap2 to do this with a remote freepbx machine? I’ve had success with pap2’s just on my lan but this is the first time I’m doing it remotely.

update: I solved it so for anyone else having this problem with a linksys pap2 you need to go into the pap2 ‘advanced view’, scroll down to the section ‘proxy and registration’, ‘use outbound proxy’ must be set to ‘yes’ and the Outbound proxy must be :, in my case this was Then it connected and registered.