Solved: Cisco 7940: handle_request_invite: Failed to authenticate device

can anyone help me understand please why a cisco 7940 phone registers fine with freepbx and yet cannot make calls? The phone is configured as extension 22 and the freepbx sip console shows:
“handle_response_peerpoke: Peer ‘22’ is now Reachable.”. So that means it’s registered, is that right? If I do ‘sip show peers’ it shows:
Name/username Host Dyn Forcerport Comedia ACL Port Status Description
22/22 <ip-of-extension> D Yes Yes A 5061 OK (584 ms)
Status saus ‘OK’ sa that means it’s good to go, is that right?
Yet when I try to make a call I get:
handle_request_invite: Failed to authenticate device "22"
I’ve been hammering at this for two days and I’m going insane. Thanks for any help.

The 584 msec round trip time might be part of it - that’s a half second. The message “is now reachable” also implies that the phone was reachable, then wasn’t, and now is again.

I’m gonna go with network problems to start.

Keep in mind that these phones can be a real bear to get working in SIP mode - they weren’t designed for SIP and don’t really have the horse power to do it well. The 8 character password limitation makes them completely inappropriate for anything but the most local of isolated PBX installations.

If you want to switch it back to the native SCCP mode, you can use something like chan-sccp-b or one of the other SKINNY protocol drivers. I wrote a Wiki article on the chan-sccp-b website on how to install the driver and the configs to make these work.

thanks for your response dave, I actually solved it. The only thing that worked was:

  1. change the cisco phone config to port 5061 (in sipdefault.cnf)
  2. change the freepbx extension setting to 5061
  3. change freepbx asterisk sip setting to 5061.
    I don’t understand why it wouldn’t work on port 5060 but it just would not.