SOLVED Can't get Grandstream GXP2170 to configure with EPM

FreePBX Distro15
Grandstream GXP2170

Everything is set up correctly on the FPBX EPM side I believe… Provisioning protocols http, https, tftp all enabled with the default ports.
Phone on latest firmware

I’ve given up on DHCP option 66. Just trying to get the damn thing to even try and talk to the PBX.

I log into the phone web interface > maintenance > upgrade and provisioning

Turn off allow option 66 to override
under the config section I put the IP of the Pbx in the config server path field (tried with the FQDN as well).

Remove all the setting from the firmware server field.

Save and apply, reboot…

Nothing… doesn’t even appear to try.

It’s gotta be something simple I’m missing here… Anyone have advice on getting these phones to provision with EPM??

Took a bit of playing but I’ve gotten the GXP2170 to work with OpenVPN AND EPM.

The general procedure is this:

Configure the PBX and EPM as you would for Sangoma phones that will use OpenVPN.
You will need to log into UCP and download the OpenVPN files for each extension.
Boot the 2170 and log into it’s web ui
Network > OpenVPN Settings

OpenVPN Enable = yes
OpenVPN Server = PBX public address
OpenVPN Port = 1194
OpenVPN Transport = UDP
(upload the appropriate files that were downloaded from UCP)
OpenVPN Cipher Method = Blowfish
OpenVPN username = blank
OpenVPN password = blank
OpenVPN Comp-Izo = Yes
Additional Options = Blank

Reboot the phone.

EPM > Global Settings > Internal address = (which should be the OpenVPN server IP)
EPM > Global Settings > External Address = PBX Public IP

EPM > Grandstream Template

Destination Address = Internal
Provision Server Protocol = HTTP
Provision Server address = interal

Configure the rest of the profile as needed, save end rebuild configs

EPM > Basefile Edit > Grandstream template > Select GPX2170

edit the following settings

Network/OpenVPN Settings OpenVPN Enable. 0 - No, 1 - Yes. Default is 1 Number: 0, 1 Mandatory
P7050 = 1
OpenVPN Server Address String
P7051 = (your PBX’s public IP)
NATTraversal. 0-No, 1-STUN, 2-keepalive, 3-UPnP, 4-Auto, 5-VPN. Default is 0.
P52 = 5

Save and rebuild config(s)

The phone should now be rebooted and you can log into the web interface again and go to:

Maintenance > upgrade and provisioning

Turn off Allow DHPC option 43 and option 66 to override server


Set Config Upgrad via = http
config server path =
Config server username = (get this from system admin > provisioning protocols)
Config server password = (get this from system admin > provisioning protocols)


Firmware server path = (delete anything in here)

Save and apply

Then from the very top menu in the phone web UI click:


The phone should now provision and grab all the settings from EPM.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.