[SOLVED] Asterisk version confusion

I sure confused . . . I currently have a functional 32-bit FreePBX that has been in use for about two year, now. I am building a 64-bit box and would like to backup my current configuration and restore it to the new 64-bit box. I installed 6.12.65 (the current iso image) and it shows “Asterisk version 11.18.0” my existing 32-bit shows “Asterisk version 12.8.1”. The ‘System Admin’ shows the same 6.12.65-28 with firmware on both versions. Is this something unique to the 32-bit version software? It having a newer (12.8.1) version than the 64-bit (11.18.0) version? Can I backup the 12.8.1 version and restore it to the 11.18.0 version?

Asterisk versions can be changed on the fly using: asterisk-version-switch

Okay, so went and tried that. It only gave me the options “Asterisk 1.8”, “Asterisk 11”, and “Asterisk 13 (experimental)”. No Asterisk 12 option?

Asterisk 12 was a Short Term release by Digium. We no longer offer that option. I suggest changing to 11 for stability issues.

So, your suggesting to switch my existing (32-bit) version back to Asterisk 11, back it up and use that (32-bit) restore on the newer (64-bit) machine?

After some reading and discovering that version 12 will be end of life in December 2015. Not thinking (sorry to disagree with you) that it is a good idea to “revert” to an older version (v11.) And the fact that version 13 was released six months ago or so and it is an LTS version. I decided to upgrade both old and new to version 13 . . . and it worked out okay. I backed up the old and restored to new and now I have issues with endpoint management . . . which is a whole different issue. So, I consider this a closed issue (Version Confusion) and I can move on and tackle my endpoint issue. I see a solution in the near future and it involves FreePBX . . . as usual. Thanks, everyone.