Solved : Asterisk switched to 13, Digium phones module broken

Hi, I switched over to Asterisk 13 and now the digium phones modules is broken, when clicking on it the following message come up.

A valid license for was not found.
Obtain/register a license.

i have tried registering the license again but no luck, the license does exist in the folder, i tried removing the module and installing again, again no luck.

any help would be appreciated.

I have tried it on another freepbx machine that I keep spare for testing and its the same thing on this machine too

mv /var/lib/asterisk/licenses/yourlicensekey /var/lib/asterisk/licenses/yourlicensekey.bak

Thanks for the reply Overkill,

unfortunately it didnt work.I registered again and it did create the .lic file again but same error.

one thing i did notice, on the digium phones screen it says:

A valid license for was not found.
Obtain/register a license.

but when i search for the file I cant find this name but i can find:

(with the ‘s’ on the end of the word phone missing)

ok i did a clean install on a test server without any other configuration at this point the digium app was working (after registration), when i did a switch over to asterisk 13 it broke the app. Also switching back to asterisk 11 doesnt fix the problem

Sounds like this is going to go beyond my ability to help you :cry:

The license should be hardware based, the version of asterisk shouldn’t affect it…

Solved :smile:

mv /usr/lib/modules/res* /usr/lib64/modules/ fixed it

This solution helped me. However, I had to use:

mv /usr/lib/asterisk/modules/res* /usr/lib64/asterisk/modules/