[SOLVED] Apply Configuration and 'Reloading' taking 10 minutes to Apply changes

Hi Everyone,

I think I have a problem similar to this thread:

I’m getting the same errors relating to GPG. The issue in the above thread was resolved by opening a port on the firewall, which is something we can’t do. We are behind a http proxy and do not have direct access to / control over the internet.

It hasn’t always taken an age to amportal a r, we started getting long pauses after a module update that I applied on the 2nd January 2015.

We are running version 5.211.65-19 and has been that way since we installed in the summer (we haven’t attempted to upgrade). All the modules are up-to-date.

The errors I’m seeing are when attempting a amportal a r :

[[email protected] ~]# time amportal a r

Fetching FreePBX settings with gen_amp_conf.php..

Successfully reloaded

real	10m18.090s
user	0m3.546s
sys	0m1.189s

the freepbx_dbug gives this output:

2015-Jan-13 11:47:27 /var/www/html/admin/libraries/BMO/GPG.class.php:510
[DEPRECATION_WARNING]: Comments starting with ‘#’ are deprecated in Unknown on line 22

2015-Jan-13 11:47:28 /var/www/html/admin/libraries/BMO/GPG.class.php:510
[DEPRECATION_WARNING]: Comments starting with ‘#’ are deprecated in Unknown on line 24

2015-Jan-13 11:47:28 /var/www/html/admin/libraries/BMO/GPG.class.php:510
[DEPRECATION_WARNING]: Comments starting with ‘#’ are deprecated in Unknown on line 24

2015-Jan-13 11:47:28 /var/www/html/admin/libraries/BMO/GPG.class.php:510
[DEPRECATION_WARNING]: Comments starting with ‘#’ are deprecated in Unknown on line 31

2015-Jan-13 11:47:28 /var/www/html/admin/libraries/BMO/GPG.class.php:510
[DEPRECATION_WARNING]: Comments starting with ‘#’ are deprecated in Unknown on line 21

2015-Jan-13 11:47:29 /var/www/html/admin/libraries/BMO/GPG.class.php:510
[DEPRECATION_WARNING]: Comments starting with ‘#’ are deprecated in Unknown on line 23

I have attempted to hack the above mentioned file by adding http-proxy=xxx to the gpg options (even though it’s already an environment variable). I have also tried to force gpg to use port 80 by removing the first option of the key servers in that file. Sadly neither of these approaches worked so I have reverted the file back to defaults.

If anyone has any ideas how I can get round this it would be appreciated.

Can you resolve the PGP servers and are you able to connect to them using say telnet:-

[[email protected] admin]# telnet pgp.mit.edu 11371
Trying 18.9.60.141…
Connected to pgp.mit.edu.
Escape character is ‘^]’.
^]
telnet> close
Connection closed.
[[email protected] admin]#

Thanks for the reply byteguy.

I can’t telnet into the PGP servers, we’re fairly well locked down here, as we’re behind a firewall that’s not under my control I don’t think we can open up that port either.

As I said above this didn’t use to be an issue so I’m not exactly sure why it’s suddenly become one?

This should be resolved in framework 12.0.31

This is for GPG module verification.

For clarification @NetworkSeb you are already updated on the FreePBX side, so I am unsure why you think you haven’t upgraded. The only thing you haven’t updated is the distro part.

Thanks, just upgraded to 12.0.31 and amportal a r takes just 30 seconds, I’ll take that!

[[email protected] ~]# time amportal a r

Fetching FreePBX settings with gen_amp_conf.php..

Successfully reloaded

real	0m30.444s
user	0m3.356s
sys	0m1.124s

Thanks very much for your help!