[Solved]2.8 upgrade problem

I upgraded successfully from 2.6 to 2.7 but when I upgraded from 2.7 to 2.8, I could successfully upgrade, but when I tried to restart amportal, I got the following errors:

1)retrieve_conf failed, config not applied
Reload failed because retrieve_conf encountered an error: 1
Added 1 minute ago

  1. function: core_routing_getroutepatterns has been deprecated and removed Array ( [0] => Array ( [file] => /var/www/html/admin/modules/core/functions.inc.php [line] => 5429 [function] => die_freepbx
    Added 1 minute ago

After checking further, I have seen that the default IVR ‘Main Menu’ seems to have been causing problem. The FP webgui has a checkbox to disable against “Enable DirectoryLet callers into the IVR dial ‘#’ to access the directory. WARNING: this feature is deprecated and will be removed from future versions. You should install the Directory module and assign an IVR destination to use Directory functionality.” but the save buttons were disabled (grayed out)?

Please hint to overcome this problem. Just stuck in limbo.

Thanks for help. Z

EDIT: It is solved. The problem is an incompatible module called extended routing. I disabled it and the problem solved. :slight_smile: