Softphone refuses to connect to SIP server


(Honor's Haven It) #1

Hello, I’m just having a small issue with the Softphone whenever my PC resets (Thanks windows 10.). Upon reset, the PC loses connection with the SIP server. Listed on screen are my SIP settings, softphone & Local IP settings. they all match, but the Softphone isn’t communicating with the SIP server. Any Ideas?

image


(Honor's Haven It) #2

Alright, so I’ve been able to get the Softphone to connect, and it can receive calls from our system, but it gives me an error of ‘not acceptable here’ when attempting any form of dialing OUT from the softphone. I’m unsure what settings to modify in the system as I’ve had to modify some of the settings via trial and error whenever the PC resets.

Below is current settings that allow the soft phone to TAKE calls, but not MAKE any calls.

Any recommendation?

image


#3

your external ip needs to be a routable address from the rest of the internet.


#4

Not acceptable here usually is one of two things, codec mismatch or encryption mismatch.

In MicroSIP, set Media Encryption to Disabled and Enabled Codecs to G.711 u-law and G.711 A-law. Disable video.

If you still have trouble, paste a log of a failing call (including SIP trace) at pastebin.freepbx.org and post the link here.


(Honor's Haven It) #5

So the public IP I would find via whatsmyip.org? I’ll set it to that


(Honor's Haven It) #6

I unchecked the Encryption and it dials out without issue. Our IP for our equipment changed from our ISP recently as well, so that would also explain why it was freaking out as well. Thank you both for your assistance! Hopefully, this PC resetting won’t break the soft phone again!