Softphone connects fine, but Yealink desk phone does not

Good day,

We’re having a strange issue where a Yealink T48G phone fails intermittently to connect to a PJSIP extension. It works off/on.
Tried resetting the phone etc, and I think that has helped in the past, but tried that recently, and it did not resolve the issue.
However, it works fine from a softphone app on a mobile device.

In the past when we had this issue, if I recall correctly, when I looked at the Asterisk log, I could not even see attempts for the Yealink to connect. So somehow the SIP traffic was not making it from the phone to the FreePBX server.
also I’m fairly confident it’s not an incorrect user/name password programmed into the phone.

Have any of you run into a similar issue? (where a desk phone will not connect but softphones do)

Thanks for your help!
Shawn

How is the network configured? Are both devices (softphone and desk phone) in the same network? Do you use a firewall? Can you SSH to the phone and check if you can reach the FreePBX server?