Softphone app not registering to freepbx inside local network

Hi all,

So I have an issue. My softphone app is not registering to freepbx when I am connected to the same network where I’m hosting the freepbx. When on other networks, it works fine. At first, I had setup my softphone app with the IP address of the freepbx but now am using a ddns and it’s still the same. Anyone know why?

I assume network means NATted LAN.

Are you trying to register with the public or private address? I think routers often won’t allow their own public address to be used from inside the NAT boundary.

Generally though, there isn’t enough information, Start with using sngrep to see if the REGISTER even reaches the machine running Asterisk. If it does. Look if the response is going back to the right place and that the Conteact headers are correct.

Yes it’s a NATted LAN. I am not sure what sngrep is?

Thanks. Also do you possibly know how I can lengthen the ring time? It seems every time I try to call someone, it rings for about 20 seconds and then gives me the line busy message from freepbx. I want to turn off all of that freepbx stuff, so it rings indefinitely for both outgoing and incoming.

However, I believe the default is 30. 20 sounds more like a network limit.

I’ve increased the ring time in both advanced settings and in each extension but no change.

Especially if calling a mobile number, at 20 seconds, it is likely to be the destination phone network. To be sure, you would need to use sngrep, or other means of capturing the SIP traffic, and also get an Asterisk full log, from FreePBX, to make sure that the intended time limit is being set.

Did you remember to reload the configuration after making the change in the GUI.

(Other means can include tcpdump and wireshark, and using the Asterisk CLI to enable logging by the channel driver (pjsip set logger on or sip set debug on).)

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.