SNOM 320 not registering with FreePBX

After having both a soft phone on my laptop and soft phone on iPhone I thought that connecting a designed for VOIP phone would be very straightforward. I have had no luck in getting this phone to register with the device account I have setup. I am using the IP address of my server in order to rule out DNS.

As I’m running on Ubuntu 10.04 LTS then I’m stuck with asterisk and using FreePBX

So FreePBX believes that there is only my soft phone registered. The SNOM 320 thinks it’s registered as well but FreePBX doesn’t agree.

Here’s the really odd thing.

If I call my soft phone extension on the SNOM then it rings. I can hear voice from SOM->soft phone but not the other way round.

If I call the SNOM extension from the soft phone then I get an immediate Service Unavailable message.

So if it was a complete failure of communication then that would be one thing. But it isn’t. It appears that some aspect of the SNOM 320 has registered but not all.

This does not make sense.

Can anyone please advice me on what the error is and how to resolve it?

Are the server and all the phones on the same network?

Yes the phones are all extensions of the same server.

I did not ask if they are on the same server, I asked if they are on the same network (LAN segment) or are some of the phones out on the Internet?

This sounds like a NAT problem and I need to know your network design.

Sorry saw network and replied server. I have gone through the NAT settings as I thought that was the most likely of problems.

I have both my laptop, using Blink Lite, and the SNOM320 on a home network. Both of these are connected to a BT home hub which is my connection to the internet.

The FreePBX / Asterisk server is set up on a cloud server accessible on the internet.

So soft phone on my home network through my router to the asterisk server works and it all registers.
SNOM320 on the same network does not.

Sure it does, your home router can’t make the u-turn for the audio path (nor apparently for the signalling).

Assuming the SNOM is programmed correctly for NAT traversal (you didn’t say what version of SNOM code. Some release of 8 are very broken, 7.x works great) I bet it would work if you shutdown the softphone. Reboot the firewall then reboot the SNOM.

If your router has any SIP ALG’s turn them off.

Thanks for the help so far SkykindOH. But to clarify are you saying that it is not possible to have more then one SIP device on a home network connected to an asterisk server on the internet? I thought that was the whole point of asterisk?

However I still get no connection even with the soft phone turned off so that’s not the issue.

To rule out the snom I have just tried soft phone to soft phone between my laptop on the home network and an Android phone. Again both devices have registered without issue.

However after phone registers I then call the correct extension fro m the laptop to phone. No service.

Phone laptop extension from phone that works.

Immediately call the same extension from laptop and that works. If left for > 30 seconds same no service.

So it looks like I now have 2 issues.

  1. SNOM320 does not register with my FreePBX / Asterisk setup - even if it is the only SIP device on the network.
  2. Andriod phone (Samsung Galaxy series Y) reports being correctly registered and correctly calls out. But cannot be called unless 30 seconds after the phone has called.

The SNOM version is 7.3.14

The reason why I cannot register is that I am getting 401 from my asterisk server. However I have entered everything correctly and a soft phone with the exact same settings works. So why is the SNOM320 not working with the correct information?

From the SNOM SIP log

Sent to at 3/7/2012 20:03:31:603 (710 bytes):
Via: SIP/2.0/UDP;branch=z9hG4bK-f9vdf5e1v8j2;rport
From: “SNOM320” sip:[email protected];tag=db9hqmyfk9
To: “SNOM320” sip:[email protected]
Call-ID: 3c26701aa20d-scye6hcuyrzr
Max-Forwards: 70
Contact: sip:[email protected]:2048;line=tqlbacyy;reg-id=1;q=1.0;+sip.instance=“urn:uuid:c3ce8633-ebe6-4c7b-8f95-f2c1d6ebf43b”;audio;mobility=“fixed”;duplex=“full”;description=“snom320”;actor=“principal”;events=“dialog”;methods="INVITE,ACK,CANCEL,BYE,REFER,OPTIONS,NOTIFY,SUBSCRIBE,PRACK,MESSAGE,INFO"
User-Agent: snom320/7.3.14
Supported: gruu
Allow-Events: dialog
Expires: 3600
Content-Length: 0

From the SNOM log

[2]3/7/2012 20:01:57: Registrar [email protected] refused with code 401
[5]3/7/2012 20:01:57: Will try to reregister in 300 seconds
[5]3/7/2012 20:02:15: Settings applied!
[2]3/7/2012 20:02:28: Transport Error: Pending packet 1000007: generating fake
[2]3/7/2012 20:02:28: Registrar [email protected] timed out
[5]3/7/2012 20:03:20: Settings applied!
[2]3/7/2012 20:03:31: Transport Error: Pending packet 1000008: generating fake
[2]3/7/2012 20:03:31: Registrar [email protected] timed out
[2]3/7/2012 20:05:03: Transport Error: Pending packet 1000010: generating fake
[2]3/7/2012 20:05:03: Registrar [email protected] timed out
[2]3/7/2012 20:06:34: Transport Error: Pending packet 1000012: generating fake
[2]3/7/2012 20:06:34: Registrar [email protected] timed out
[2]3/7/2012 20:08:06: Transport Error: Pending packet 1000014: generating fake
[2]3/7/2012 20:08:06: Registrar [email protected] timed out

The key settings from identity 1 of SNOM are


DisplayName: SNOM320
Account: 2222
Password: [password]
Registrar: [server IP address]


Long SIP-Contact (RFC3840): On
Support broken Registrar: Off
Server Type Support: Asterisk


Offer ICE: Off
All other settings are blank

Given the above information why does my SNOM320 fail to register but soft phone works as expected?

After a week with SNOM trying to find what is not configured with the phone they have come back and stated that the fault is with Asterisk.

In the SIP log I can see the following

SNOM320 sends a REGISTER to the Asterisk server
Asterisk server sends back a 401
SNOM320 sends a modified REGISTER back to the Asterisk server

And then my SNOM320 keeps sending the register command but the asterisk does not respond back. This is what SNOM says is purely a fault with the asterisk setup. Using my settings they can connect to a “Asterisk PBX” with no issue.

So why doesn’t my Asterisk reply back to the second REGISTER? What config and value should I be looking at?

Thanks, Ian

I don’t know if it’s an Asterisk issue or not but I go back to my original assertion that if you put the phone on the same network I bet it will work fine.

Anyway, how can we tell you anything about Asterisk since you did not tell us what version of Asterisk you are running.

The version that SNOM mentions is an old hacked up Fonality (trixbox) version and is ridiculous that they are using that for Q&A.

In my first post I wrote “As I’m running on Ubuntu 10.04 LTS then I’m stuck with asterisk and using FreePBX”.

I agree that SNOM using such an old version of asterisk is ridiculous. I have, politely, asked them to test with a more recent version of asterisk and see if their phone still works in their lab.

Sorry I missed that. Why are you stuck with that version of Asterisk?

It’s EOL. I would download the current stable 1.8 from Digium.

Would that be the under the LTS section? (URL

Having used Debian systems I know that they tend to be a bit behind everyone else which is why I didn’t think I could go above the 1.6 version. But this is Ubuntu which is normally a bit closer to the current world. I’ll download that tarball and make sure it compiles.

I’ll also prod Snom to see if I can get them to give a definitive answer as to if their phone will talk to a 1.8 server.

I’ve taken a clone of the setup I have on the cloud server and set that up on a laptop internally to my home network. All I had to do was change the IP address on the phone settings and it all registers. So the phone does work with the version of asterisk I have and it’s a NAT problem as previously suggested by SkykingOH.

Haven’t yet seen an obvious setting for ALG on the router I have but will be checking that. Are there any other settings I need to be looking at?

Thanks for the help so far.

Don’t use a BT Home Hub. Finding an older Netgear router and connecting the SNOM320 through that then registered and worked as expected.

It seems that the BT router is expecting to work with a specific SIP device and won’t play nicely with anything else and there is no ability to configure the ALG configuration to work around this.

Thank you SkykingOH for all of the help you have provided.

I am new to asterisk after building a single system a few years ago. Can someone recommend phones that are well supported. In other words, I need to decide what phone hardware to buy (most likely used) and I need to end up with phones that the software is available for. Also, if you can point me to where I can download the phone software, that would be great. Thank you for the help.

Hi there, my system FreePBX 2.11 with Asterisk 10.4 work pretty awesome with Snom-320 (which is also latest firmware 8). But I have a grossly outdated and discontinued long time ago Snom-190 with its latest firmware 3.60 which is actually many years old as well at this point. This phone exhibits the same behavior as OP mentioned. I get a successful registration for 30 sec. During which I can place calls and operate the phone in every other way, but after 30 seconds, it looses registration and asks for password. In its log it says

[5]31/1/2014 12:06:16: Match challenge for user=972, realm=asterisk
[5]31/1/2014 12:06:16: Match challenge for user=972, realm=asterisk
[5]31/1/2014 12:06:16: Match challenge for user=972, realm=asterisk
[5]31/1/2014 12:06:16: Match challenge for user=972, realm=asterisk
[2]31/1/2014 12:06:16: Registrar [email protected] refused with code 401

It looks like in newer phones such us 320, Snom probably changed the way phone responds to the “refusal”… My 320 has this in the Log

31/1/2014 12:09:07 [WARN ] PHN: SIP: process_registrar_packet: 401 needs 128 bit nonce

If anyone figured out how to make these old phones such as my Snom -190 work, please share. Thanks,