SNMP Configuration Asterisk 11

Hello guys, I have been trying to configure SNMP on my Freepbx over the last several hours and cannot seem to get PRTG to monitor various OID’s

First none of the Asterisk OID’s are avail when I run a: snmpwalk -On -c public -v 2c localhost asterisk
I get the following: . = No Such Object available on this agent at this OID

I have followed several (outdated guides) including one more recent guide:

However still not able to get this to work. Any ideas?
version info: Asterisk (Ver. 11.16.0) FreePBX: FreePBX 12.0.65

You will need to rebuild asterisk with snmp support

Ok sorry but how do I go about doing this? Why isnt this already built into the product?

You would have to ask “the product” :slight_smile:

You ask in “general help” so generally when you build asterisk you would do that in the

make menuselect

stage and choose res_snmp, if you have the prerequisites it will be built.

Oh I apologize was I supposed to ask this question in a more specific forum? I have the FreePBX Distro.
So as it relates to Free PBX Distro (Not a fresh install) what needs to happen?

** EDIT just moved topic to Distro **

If you are using the FreePBX Distro you need to install the Asterisk SNMP RPM (yum install asterisk11-snmp).

Package asterisk11-snmp-11.18.0-1.shmz65.1.75.x86_64 already installed and latest version

Probably from the site I referenced above where by he talks about installing on Asterisk 11.

Any other ideas on this subject?

Wow lots of crickets in here… Has anyone got this working???
Perhaps some formal documentation is needed.

It works fine . For documentation and mibs go to Digium.

Oh thanks Dicko… thats was an amazing response… I see you dont bother to look at what I have done… Its not working for me… How about helping me find a solution.

Once again I will post this link:
I have followed to the T, and it doesnt work.

Basically you just need Install asterisks res_odbc. Get the mibs from Digium, install and configure net-snmp for your os and find a client that suits you. I can’t help you as to why your recipe didn’t work for you :slight_smile: maybe you should contact the author

Dicko that Recipe came from these forums… perhaps again I might suggest that FORMAL documentation on the subject is created. I just spent the last 30 min looking up or decoding what your comment said about asterisks res_odbc and found several out-dated material. Nothing for Asterisk Version 11 or FreePBX Version 12. Shall I risk following old documents? Or Can I get a better recipe that is supported by FreePBX.

That recipe was “linked to” by a forum member. It bears no Freepbx imprimatur Generally FreePbx has a great wiki. Google also can help you learn stuff like snmp. If you get impatient there is always ‘paid support’ linked above.

Awesome please provide me with the link on FreePbx Wiki that explains SNMP… because I did attempt to GOOGLE it and nothing came up. I agree that the wiki is great, however on this subject the documentation is weak.

Sorry I won’t do your research or work for you.

Right so what your saying is that there is no such documentation… I know because I have searched… Thanks for your help Dicko…

SNMP and MIBS comes up every so often, if anyone would like give back and do a little documentation in the wiki we can create an article in the appropriate location and provide access to write/edit those wiki pages. Typically what happens those that are using snmp in their environment are more of a commercial focused group, so stuff doesn’t always make it back in to the community.

1 Like

I would be glad to if I can get my system working with some guidance…