SMTP relaying not allowed

Im having issues getting FreePbx to send SMTP emails.

Any ideas what I can do to fix this?

Here is my log. Relaying disallowed. Is postfix acting like a relay instead of a email client? Is there a way to get postfix to act like a client instead of a relay?

Oct 31 19:11:13 freepbx postfix/smtp[31946]: 1DB991217384: to=[email protected], relay=smtppro.zoho.com[ip address removed]:587, delay=0.78, delays=0.03/0.03/0.52/0.21, dsn=5.0.0, status=bounced (host smtppro.zoho.com[ip address remoed] said: 553 Relaying disallowed as [email protected] (in reply to end of DATA command))

Relays are back to back user agents for SMTP as well as SIP.

It is actually the smtppro that is being asked to act as the relay. Either it doesn’t recognize you as a legitimate sender, or it is expecting you to use the mail submission port, 587, rather than the primary port, and originally the only one 25.

The only other option that postfix would have, other than using a relay is to direct deliver to the destination incoming server, but these days, in the same way that few people allow direct SIP, most people will reject attempts to direct deliver from unknown clients and only accept traffic from well known relays, acting a clients.

for homemade use you may edit your /etc/postfix/main.cf and add some files.
If you have a working mail-server in your local IP environment, and just want to send to your local users, it would be enought to enclose to your /etc/postfix/main.cf on the freepbx the following:
relayhost = 192.168.50.18:25
myhostname = pbx-virtual
mydomain = yourdomain.tld
myorigin = pbx-virtual.yourdomain.tld

If you have external e-mail receipiants, it’s quite a little bit more:
similar as above + your relayhost needs to be an URL:587 or URL:465 where you need to identify yourself with
smtp_sasl_auth_enable = yes
smtp_sasl_password_maps = hash:/etc/postfix/sasl_passwd
smtp_sasl_security_options =
smtp_use_tls = yes

user and access are stored in sasl_passwd and hashed with postmap.
In addition you may re-write pbx users (e.g. asterisk and root) within
smtp_generic_maps = hash:/etc/postfix/generic

However, your relay needs to allow your sender to send under falsed flag, or you re-write all senders of your pbx into the real sender’s e-mail of your relay-user.

In addition you may have a look into your /etc/aliases and see whether or not it fit your needs.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.