Slow Reloading after applying config

i am using FreePBX Distro 32bit, Asterisk 11.5.0 and FreePBX 12.0.36

Recently Applying Config takes a long time to reload. I’ve tried restarting. it does not help.

There are 20 extension and 5 trunks in this deployment.

What can i do to make it fast?

Has anything changed in your system recently?

i installed A2Billing in the same server.
This is a VM allocated with 2GB RAM and 2 core of Intel Xeon E3 @ 3.1Ghz

Check the addresses of the DNS servers in /etc/resolv.conf. Make sure they are valid, and make sure they can resolve by testing with nslookup, or ping

FreePBX hangs for upwards of 2 minutes if it can’t contact the internet. I recently had a system in a building for about a week where we had no internet. It was such a chore to have to apply then wait a full 2 minutes for every change.

I have the same problem too…

nslookup and ping resolve ok

Do you have a lot of voicemails?

@Andrew, would you like me to start a new thread, mine might me proxy server related



No new thread is required. This sounds exactly like

Here is my problem though, there seems to be no where to make the system aware of the proxy server. This system is located at a school and the proxy is provided by the education authority so I have no control over it.

I am also unable to do updates as per this post here:

The fix mentioned didn’t work in my instance.

I can only assume that the authority has made a change ( i tried asking but no one knew…), as this system was working fine up till now.

Both nslookup and ping work ok to the outside world. (mirror1 returns

What / Where can i edit to insert the proxy server details?



We dont support proxies at this time. I would say your issue is unrelated to this thread and to the other thread. Getting proxies to work is in the list. However they have never worked.

Go to Advanced Settings and look for the option to “use wget” switch the setting, disable module admin cache mode and then go check online.

no. it’s a new system.

ping and nslookup is working fine. the Apply config is still slow after changing to Google DNS.

That doesnt mean you can connect to the GPG keyservers which still goes back to my original point. Ping and nslookup only tell you if it’s DNS. If you read the thread I linked to you would see there is no mention of DNS in there.

how can i check if i’m able to connect to GPG keyservers? I am definitely able to connect to WAN as my IP Phone is connected via public IP. i have no problem updating modules too.

here is what i tried after reading your post - stop IP tables, allow any traffic from WAN to LAN and LAN to WAN. no joy. still took 1minute to complete reloading.

@tm1000, any help on this?