Slow outbound call connection [included asterisk log files]

I see this is a common issue likely related to network/DNS settings. I’m noticing really slow (8-9 second delay) in connecting the call.

Here are entries from the Asterisk log files:

Your log shows only 2 seconds from when Asterisk got the call until VZW signaled ringing (quite good), then another 4 seconds until answered. I am guessing that the device making the call did not send it immediately to Asterisk, because it was waiting for more digits.

What device made the call (IP phone make/model, softphone name/version, mobile app name/version, ATA make/model, etc.)? If the device was an ATA or similar gateway, what kind of phone was connected to it? How did you make the call (dialed manually, redial button, selected from contacts, etc.)?

On the receiving end, about how log after ringing started was the call accepted?

Softphone: Blink 3.2.0

FreePBX is hosted on Oracle VM VirtualBox, with Bridged Adapter enabled in network settings for the VM.

The issue can be replicated when dialing manually, redial & selected from contacts.

Also worth noting, it’s the same amount of delay when ending the call. There’s a noticeable gap from the time I release the call to when the call disconnects and the softphone makes the audible noise indicating the call ended.

Where is the time discrepancy? Bring up a clock on the PC running Blink, e.g., Confirm that the date command on the PBX shows within one second of the same time. Now make the call and record when you pressed call, when you heard ringing start, when the mobile actually started to ring, etc. Report those times and paste a new log for comparison.

The delays could be caused by DNS or STUN lookups, scheduling, etc.

After a reboot of my host machine, the delay is no longer there. However, now I’m not getting any audio from either end of the call on either inbound or outbound calls. I’ve tried on the Blink softphone as well as Zoiper. I’ve attempted adjusting input/output audio devices. I even put the call on hold on Blink (usually hold music plays) and didn’t get any hold music on the mobile device.

The log has little useful information. It just shows a call ending, and pjsip logger was off. Please paste a more complete log.

My apologies. I enabled pjsip logging and made sure to copy more complete info. Thanks for your patience.

The immediate cause of no audio is that in the outgoing INVITE starting on line 3785, Asterisk sent its private IP in the SDP (line 3808), instead of its public IP. But strangely, the Contact header (line 3790) does have the correct public IP.

In Asterisk SIP Settings, General tab, confirm that External Address and Local Networks are correctly set. On the chan_pjsip tab, in the (udp) section, Port to Listen On is 5060 and all the other fields should be blank. If you change these, after Submit and Apply Config you must restart Asterisk.

If you still have trouble, at the Asterisk command prompt type
pjsip show transport
pjsip show endpoint fpbx-1-Ie4Kg5cfludr
and post the output of both commands.

This was the problem. I double checked my Local IP and saw that I had it listed as my EXT. IP. We have audio! Thank you for your help and quick responsiveness.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.