Skype on FreePBX - Error making Outbound calls

Hello,
I am setting up Skype on Asterisk. Registering Skype on Asterisk to Skype was a snap and I have verified on Skype Manager it is registered. I setup a trunk and an outbound route to use the skype setup. Pressing 7 first will use the appropriate trunk/outbound route. I have verified this based on the log files. When I make the call I always get the messages the “All circuits are busy.” I paste the log below. The Key error is "TRUNK Dial failed due to CHANUNAVAIL (hangupcause: 3)

Any help is appreciated.
FreePBX in a Flash v1.4
Asterisk 1.4.21.2

Connected to Asterisk 1.4.21.2 currently running on pbx (pid = 3193)
Verbosity is at least 3
– Executing [[email protected]:1] Set(“SIP/268-b770b848”, “MOHCLASS=Soft-Jazz”) in new stack
– Executing [[email protected]:2] Macro(“SIP/268-b770b848”, “user-callerid|SKIPTTL|”) in new stack
– Executing [[email protected]:1] Set(“SIP/268-b770b848”, “AMPUSER=268”) in new stack
– Executing [[email protected]:2] GotoIf(“SIP/268-b770b848”, “0?report”) in new stack
– Executing [[email protected]:3] ExecIf(“SIP/268-b770b848”, “1|Set|REALCALLERIDNUM=268”) in new stack
– Executing [[email protected]:4] Set(“SIP/268-b770b848”, “AMPUSER=268”) in new stack
– Executing [[email protected]:5] Set(“SIP/268-b770b848”, “AMPUSERCIDNAME=CallIDNAME”) in new stack
– Executing [[email protected]:6] GotoIf(“SIP/268-b770b848”, “0?report”) in new stack
– Executing [[email protected]:7] Set(“SIP/268-b770b848”, “AMPUSERCID=268”) in new stack
– Executing [[email protected]:8] Set(“SIP/268-b770b848”, “CALLERID(all)=“CallIDNAME” <268>”) in new stack
– Executing [[email protected]:9] ExecIf(“SIP/268-b770b848”, “0|Set|CHANNEL(language)=”) in new stack
– Executing [[email protected]:10] GotoIf(“SIP/268-b770b848”, “1?continue”) in new stack
– Goto (macro-user-callerid,s,19)
– Executing [[email protected]:19] NoOp(“SIP/268-b770b848”, “Using CallerID “CallIDNAME” <268>”) in new stack
– Executing [[email protected]:3] Set(“SIP/268-b770b848”, “_NODEST=”) in new stack
– Executing [[email protected]:4] Macro(“SIP/268-b770b848”, “record-enable|268|OUT|”) in new stack
– Executing [[email protected]:1] GotoIf(“SIP/268-b770b848”, “1?check”) in new stack
– Goto (macro-record-enable,s,4)
– Executing [[email protected]:4] AGI(“SIP/268-b770b848”, “recordingcheck|20150210-152211|1423610531.49451”) in new stack
– Launched AGI Script /var/lib/asterisk/agi-bin/recordingcheck
recordingcheck|20150210-152211|1423610531.49451: Outbound recording not enabled
– AGI Script recordingcheck completed, returning 0
– Executing [[email protected]:5] MacroExit(“SIP/268-b770b848”, “”) in new stack
– Executing [[email protected]:5] Macro(“SIP/268-b770b848”, “dialout-trunk|17|17606604690||”) in new stack
– Executing [[email protected]:1] Set(“SIP/268-b770b848”, “DIAL_TRUNK=17”) in new stack
– Executing [[email protected]:2] GosubIf(“SIP/268-b770b848”, “0?sub-pincheck|s|1”) in new stack
– Executing [[email protected]:3] GotoIf(“SIP/268-b770b848”, “0?disabletrunk|1”) in new stack
– Executing [[email protected]:4] Set(“SIP/268-b770b848”, “DIAL_NUMBER=17606604690”) in new stack
– Executing [[email protected]:5] Set(“SIP/268-b770b848”, “DIAL_TRUNK_OPTIONS=trwT”) in new stack
– Executing [[email protected]:6] Set(“SIP/268-b770b848”, “OUTBOUND_GROUP=OUT_17”) in new stack
– Executing [[email protected]:7] GotoIf(“SIP/268-b770b848”, “0?nomax”) in new stack
– Executing [[email protected]:8] GotoIf(“SIP/268-b770b848”, “0?chanfull”) in new stack
– Executing [[email protected]:9] GotoIf(“SIP/268-b770b848”, “0?skipoutcid”) in new stack
– Executing [[email protected]:10] Set(“SIP/268-b770b848”, “DIAL_TRUNK_OPTIONS=tw”) in new stack
– Executing [[email protected]:11] Macro(“SIP/268-b770b848”, “outbound-callerid|17”) in new stack
– Executing [[email protected]:1] ExecIf(“SIP/268-b770b848”, “0|SetCallerPres|”) in new stack
– Executing [[email protected]:2] ExecIf(“SIP/268-b770b848”, “0|Set|REALCALLERIDNUM=268”) in new stack
– Executing [[email protected]:3] GotoIf(“SIP/268-b770b848”, “1?normcid”) in new stack
– Goto (macro-outbound-callerid,s,6)
– Executing [[email protected]:6] Set(“SIP/268-b770b848”, “USEROUTCID=”) in new stack
– Executing [[email protected]:7] Set(“SIP/268-b770b848”, “EMERGENCYCID=”) in new stack
– Executing [[email protected]:8] Set(“SIP/268-b770b848”, “TRUNKOUTCID=”) in new stack
– Executing [[email protected]:9] GotoIf(“SIP/268-b770b848”, “1?trunkcid”) in new stack
– Goto (macro-outbound-callerid,s,12)
– Executing [[email protected]:12] ExecIf(“SIP/268-b770b848”, “0|Set|CALLERID(all)=”) in new stack
– Executing [[email protected]:13] ExecIf(“SIP/268-b770b848”, “0|Set|CALLERID(all)=”) in new stack
– Executing [[email protected]:14] ExecIf(“SIP/268-b770b848”, “0|SetCallerPres|prohib_passed_screen”) in new stack
– Executing [[email protected]:12] ExecIf(“SIP/268-b770b848”, “0|AGI|fixlocalprefix”) in new stack
– Executing [[email protected]:13] Set(“SIP/268-b770b848”, “OUTNUM=w17606604690”) in new stack
– Executing [[email protected]:14] Set(“SIP/268-b770b848”, “custom=SIP/SkypeTrunk1”) in new stack
– Executing [[email protected]:15] ExecIf(“SIP/268-b770b848”, “1|Set|DIAL_TRUNK_OPTIONS=M(setmusic^Soft-Jazz)tw”) in new stack
– Executing [[email protected]:16] Macro(“SIP/268-b770b848”, “dialout-trunk-predial-hook|”) in new stack
– Executing [[email protected]:1] MacroExit(“SIP/268-b770b848”, “”) in new stack
– Executing [[email protected]:17] GotoIf(“SIP/268-b770b848”, “0?bypass|1”) in new stack
– Executing [[email protected]:18] GotoIf(“SIP/268-b770b848”, “0?customtrunk”) in new stack
– Executing [[email protected]:19] Dial(“SIP/268-b770b848”, “SIP/SkypeTrunk1/w17606604690|300|M(setmusic^Soft-Jazz)tw”) in new stack
== Everyone is busy/congested at this time (1:0/0/1)
– Executing [[email protected]:20] Goto(“SIP/268-b770b848”, “s-CHANUNAVAIL|1”) in new stack
– Goto (macro-dialout-trunk,s-CHANUNAVAIL,1)
– Executing [[email protected]:1] GotoIf(“SIP/268-b770b848”, “1?noreport”) in new stack
– Goto (macro-dialout-trunk,s-CHANUNAVAIL,3)
– Executing [[email protected]:3] NoOp(“SIP/268-b770b848”, “TRUNK Dial failed due to CHANUNAVAIL (hangupcause: 3) - failing through to other trunks”) in new stack
– Executing [[email protected]:6] Macro(“SIP/268-b770b848”, “outisbusy|”) in new stack
– Executing [[email protected]:1] Playback(“SIP/268-b770b848”, “all-circuits-busy-now|noanswer”) in new stack
– <SIP/268-b770b848> Playing ‘all-circuits-busy-now’ (language ‘en’)
– Executing [[email protected]:2] Playback(“SIP/268-b770b848”, “pls-try-call-later|noanswer”) in new stack
– <SIP/268-b770b848> Playing ‘pls-try-call-later’ (language ‘en’)
– Executing [[email protected]:3] Macro(“SIP/268-b770b848”, “hangupcall”) in new stack
– Executing [[email protected]:1] GotoIf(“SIP/268-b770b848”, “1?skiprg”) in new stack
– Goto (macro-hangupcall,s,4)
– Executing [[email protected]:4] GotoIf(“SIP/268-b770b848”, “1?skipblkvm”) in new stack
– Goto (macro-hangupcall,s,7)
– Executing [[email protected]:7] GotoIf(“SIP/268-b770b848”, “1?theend”) in new stack
– Goto (macro-hangupcall,s,9)
– Executing [[email protected]:9] Hangup(“SIP/268-b770b848”, “”) in new stack
== Spawn extension (macro-hangupcall, s, 9) exited non-zero on ‘SIP/268-b770b848’ in macro ‘hangupcall’
== Spawn extension (macro-hangupcall, s, 9) exited non-zero on ‘SIP/268-b770b848’ in macro ‘outisbusy’

Last I knew skype for Asterisk was killed off as a supported product from Digium and thought it was no longer working or supported.

Are you using the Skype Connect - SIP Trunk or Skype for Asterisk? If the later, Tony nailed it as that has not worked for years,

I’m pretty sure Skype Connect SIP Trunk.
Here is the link I am using - http://dannytsang.co.uk/adding-outgoing-skype-for-sip-to-freepbx/
I setup Skype Connect - Easy.
I then create a SIP Trunk and am registered.
I then create an Outbound Route.
Here is my dial path which is similar to others routes I have except I prefix with a 7 to designate Skype Calls:
7|911
7|011.
7|1NXXNXXXXXX
7|NXXXXXX

As far as I know, the account that has Skype Connect “feature” must have some allowance for outbound calls. A subscription to some plan ( INTL or US Only, etc… )

Yes you are right. $$ have been allocated in the Skype Manager for this.

Progress! I reworked some things in the SIP Trunk’s Settings. I am now able to make US Calls. Now for International calls. When call an international number, I am getting TRUNK Dial failed due to CHANUNAVAIL (hangupcause: 28) on the console which is an “Invalid number format” apparently. “All circuits are busy”. I am dialing 01161396694916.
Dial plan is the same as above.
Any clues?

http://www.simplecountrycodes.com/faq

What did you change in the trunk?

It would be great to have an answer to this topic, I’m trying to do the same thing, Skype have great plans for international calls, and I want to see how to make it work. Does any of you know if you have to purchase different plans ( Europe calls, USA calls, etc ) or just add money to the outbound account on the Skype Manager and it works on its own ?

Is any of you currently using Skype for outbound? Our sales team in some countries just can’t have a good quality call with Bria from they smartphone, but if they use skype instead, the call is on a good quality.