Skype for Asterisk Do not work!

Skype for Asterisk do not work it has conflicts with AMI, MySQL, Codec issues and crashes existing systems.

Be carefule if you want to buy Skype from Digium as you may end up paying so much money fixing issue after issue!

It works fine if you install it properly. Don’t make general statements like this in the forum. Someone may read it and actually believe the statement.

The only difficulty we have had with Skype is making sure the account is loaded properly for outbound. Inbound works great.

I have never tried to “slipstream” it into an ISO distribution. I build Asterisk, Asterisk Add-ons and Skype for Asterisk from source.

Scott, I could not agree more. Nonetheless, I have run into issues just getting the install right. This is something I am going to blog in more detail, but the meat of the matter was the asterisk-gplonly bit.

I built a system with the AsteriskNow1.5 ISO and brought it up to date as it installs Asterisk 1.4.24 which is not sufficient for SFA.

Then there is the “I am probably breaking some gpl doing this, but…” fix to get SFA (or Fax for Asterisk) installed.

yum erase asterisk14-addons.i386
yum erase asterisk14-addons-mysql.i386
yum erase asterisk14-addons-core.i386

–> Now you can install Skype For Asterisk and/or FAX for Asterisk. After which:

rpm -ivh --force --nodeps asterisk14-addons-1.4.9-1_centos5.i386.rpm
rpm -ivh --force --nodeps asterisk14-addons-core-1.4.9-1_centos5.i386.rpm
rpm -ivh --force --nodeps asterisk14-addons-mysql-1.4.9-1_centos5.i386.rpm

And I seem to remember having to review amportal.conf, manager.conf and cdr_*.conf and correct a password that got set to a different “defualt” the the stock AsteriskNow1.5 install.

And the stream has been slipped…

btw, this post is in no way an endorsement for violating gpl or anything else.


I would be glad if you could provide some more exact information about how you managed to compile Skype for Asterisk on AsteriskNow 1.5. Especially about the steps what you did when you say “brought it up to date”

In order to evaluate the solution, I have just purchased a single channel license for Skype for Asterisk. I have downloaded the correct Skype for Asterisk package from digium’s site, I have gcc and Asterisk source but compiling the Skype for Asterisk channel driver fails. I have tried to compile Skype for Asterisk on Trixbox as well, but I get the same preprocessor error messages from gcc. There are so many ones that I have decided not to include them here.

I just wondering what the hell I am doing wrong since the it is only 5-6 steps to install AsteriskNow (or tixbox), gcc, download and compile the Skype for Asterisk package. Any help is welcomed

Here’s a blog on a Skype for Asterisk on an Elastix distribution.
But it can be applied to other distrib too.